Some thoughts and questions...

I have been working on a large transfer and restoration project. Something like 30 hours of recordings that need to be transferred and noise reduction applied. Wavelab had been GREAT for doing all of this. BUT I have some questions that this procedure has brought into focus.

  1. In the Open command is there a way to bring in multiple .wav files? It seems to me that it was easy in WL6 but for some reason it no longer works and I have to bring in each file separately. I am in Windows so I push down the command key, select multiple files and then only one imports. Suggestions?

  2. When I use the keyboard command “Q” and “S” to set a marker half the time the marker gets set and half the time the file is split as well. Not sure what I am doing wrong or differently.

  3. Has anyone solved the problem of not having any CD drives in the Wavelab 9.5 64 bit version? The 32 bit version works GREAT. I have done everything suggested in the WL forums and still cannot get it to work. It seems to me that GEAR promised some updates to their drivers but I cannot find any updated drivers or a program to uninstall the drivers that they promised over a year ago. Trying to contact Gear seems to be almost impossible and they never return any email I send them

I am incredibly impressed with WL 9.5 and it makes my job so much easier. Thanks to PG and others for such an amazing program.

And thanks to members of this forum for all the help over the years.

Multiple open should work just fine. If you are talking about the audio file editor, just go File / Open / [select multiple audio files from your file list] / Click on the ‘Open’ button. Or to insert audio files in a montage go to the Insert ribbon and select Audio Files / Browse / Open File Selector.

“Q” and “S” works OK to enter a splice marker here, as long as you don’t leave a gap between the two key presses, since “S” on its own performs a split. If it’s bothersome you could consider changing the key command for insert splice marker.

I have the same problem here under Windows 10.

There is no problem to solve here. On this machine I never had CD reading or writing problems from WL in the last 6 years. Started out as a Windows 7, then 8 now Windows 10 machine - 64 bits.

Not sure what happened but in Wavelab 9.0 and subsequent releases in WL 64 bit all I see is a DDP and no drives. I think it goes back to a problem I had with some defragging software I used. In WL 6 and WL 9 32 bits all the drives show up.

Thanks for the fast response.

Thanks I will try that. It was driving me crazy yesterday. Sometimes working sometimes not. I am glad I am not the only one who is still having problems with CD drives showing up in WL. Thanks for the quick response and for the help! Much appreciated.

Thomas

I had the problem of no CD drive in WL9 since a particular Windows update. In the end, it was clear that GEAR were never going to solve the problem and that Steinberg seemed completely indifferent to the issue despite the fact that for WL it was their driver of choice. As you noted GEAR never respond to emails, but somehow Steinberg does manage to contact them as PG has been told they cannot replicate the problem.

In the end, I took the plunge and followed the procedure that was linked to in a post earlier in the year, which involved editing and deleting entries in the registry among other tasks and fortunately it worked. If it had not my only recourse would have been to create a cue sheet and burn in WL6 which has no problem seeing the optical drives!

Jim

Jim,


Can you direct me to the procedure. Thanks in advance!

Thomas

I’ve copied the removal process below. You then run the driver install.

Jim

Manual Removal – 64-bit
Vista, Windows 7 and newer 64-bit
[↑]
WARNING: Modifying the registry can cause serious problems that may require you to reinstall your operating system.
We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Select Run… in the START menu, and type in regedit
This will start up the Registry Editor.

Delete the following key from the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\GearAspiWDM
In the HKEY_LOCAL_MACHINE\SYSTEM\System\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318} key remove the GEARAspiWDM entry in the UpperFilters value. Note that the entries in this value are double byte.
In the HKEY_LOCAL_MACHINE\SYSTEM\System\CurrentControlSet\Control\Class{6D807884-7D21-11CF-801C-08002BE10318} key remove the GEARAspiWDM entry in the UpperFilters value. Note that the entries in this value are double byte.

In the HKEY_LOCAL_MACHINE\SYSTEM\System\CurrentControlSet\Control\Class{CE5939AE-EBDE-11D0-B181-0000F8753EC4} key remove the GEARAspiWDM entry in the UpperFilters value. Note that the entries in this value are double byte.

Reboot

Delete GearAspi.dll (32bit) from the Windows\SysWOW64 folder
Delete GEARAspi64.dll (64bit) from the Windows\System32 folder
Delete GearAspiWDM.sys (64bit) from the Windows\System32\Drivers folder
If present, delete the Windows\System32\GEARAspi.dll value from the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\SharedDLLs registry key
If present, delete the Windows\SysWOW64\GEARAspi.dll value from the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs registry key
Delete the Windows\System32\GEARAspi64.dll value from the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs registry key
Delete the Windows\System32\Drivers\GearAspiWDM.sys value from the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs registry key

Reboot

I’m glad you posted this Jim. It shows there are typos in their instructions, like

HKEY_LOCAL_MACHINE\SYSTEM\System\

There isn’t a HKEY_LOCAL_MACHINE\SYSTEM\System\ in the Win 10 or Win 7 registry. It’s just \System.

It would be nice if they corrected this on their website, but it would be nicer if they just make a Gear Removal Tool that runs through all of this, if they’re not going to change their uninstaller to do it (which would be even better). There are too many Win 10 systems, for whatever reason, where their current installer/uninstaller simply runs in circles because the uninstaller doesn’t uninstall everything it needs to, and the repair doesn’t repair what’s needed.

The manual uninstall works (without the typos), but it took me two tries the first time because of the cryptic entry names it’s dealing with.

Jim, Thanks for posting this, bob99 I agree with your statement about GEAR. I cannot understand why Steinberg would not put some pressure on GEAR to do as you suggested. GEAR is completely unreachable through “normal channels” like Email. IMO CD burning has always been problematic with WL.

Hi Thomas, FYI I solved my drive recognition problem under Windows 10. It turned out to be an obscure Windows issue causing the drive to not be recognised by the OS. This happened after I’d updated to version 1709. I followed some advice I found on the net to go into Device Manager / IDE ATA/ATAPI controllers and uninstall all of them and then reboot the computer. After doing this the DVD drive in question was recognised again in Windows and in Wavelab. I thought I’d mention this just in case it relates to your own issue.

Thomas, if the Gear uninstall doesn’t fix things, like it wasn’t the problem for Stingray, the following should cover everything, including Gear/Wavelab problems, and/or Windows and other program problems with the drives. Regardless, the drives ‘should’ work with Wavelab after doing this:


After trying a log of things, I think there are probably 3 ‘simple’ steps to fix nearly any optical drive problems with Wavelab on Windows:
(I would make a System Restore Point before running these so you could go back if you need to).

  1. Make sure the drive is plugged in and turned on. Install or reinstall(repair) GEAR Drivers:
    http://www.gearsoftware.com/support/drivers.php

if that doesn’t work,

  1. Run Microsoft troubleshooting checklist:
    https://support.microsoft.com/en-us/help/314060/

if you deleted the registry entries in Microsoft method #5 (and only if), do the following (#3):

  1. Go to the registry (start->run->regedit.exe) and look for “HKEY_LOCAL_MACHINE\SYSTEM\System\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}”. Right click in the right section and select “New->Multi-String Value”. Name it “UpperFilters”. Right click on it and select “Modify”. Enter “GEARAspiWDM” (press enter to move to the next line and click ok) into the “Value Data”. Restart and it should be fixed. If not also try to make a “LowerFilters” and leave it blank.

(from http://ccm.net/forum/affich-77186-itune)

=============

These 3 steps should cover all cases I’ve seen anyway.

One of my interns, Luke, is a Computer Engineering student and he performed the fix that Jim and bob99 provided and IT WORKED. Thanks to one and all and I found the problem with my “Q” and “S” not working all the time. Someone had put the “repeat” rate on the keyboard to 100%. I backed it down and presto no problems. (sometimes interns change things for some unknown reason and then forget to put it back…grrrr) Thanks again, you are all GREAT!!! Have a Wonderful New Year and a Prosperous one as well. Be safe!

Glad you got it sorted !