Some VSTs rejected on one machine only (solved)

I am completely at a loss here. This is not a specific WaveLab problem, but WaveLab is one of the affected programs, so I thought someone here might have a clue.

I have two computers, a long-established desktop with loads of stuff on, and a recently reinstalled laptop (which has an SSD). On both I have WaveLab 9.1, also Plogue Bidule and Reaper in their current 64-bit Windows versions. I also have a number of VSTs (for ambisonic processing, so likely ones you have never heard of). On the desktop, all these VSTs are recognised by all these programs, and operate as they should. But on the laptop, five of them (from three different suppliers) are not accepted. In WaveLab, they are placed into the “ignored plugins” list; in Bidule and Reaper they are simply not visible.

I have checked that all the file and directory permissions are correct (in one case other VSTs in the same directory are accepted), and have failed to find any way in any of those programs to determine the supposed reason for their rejection. Permissions are in general aligned, as the machines are both in a domain and using the same login.

Any ideas, either for further debugging or for cause?


PS - I have now located the Bidule log which reports for the VSTs concerned: “HMODULE is 0”. I have no idea what this means, or why it is different on the two machines.

OK, I eventually worked out that it is a VC runtime issue. The desktop has accumulated six 64-bit VC runtimes, whereas the laptop has only got one. Installing the latest VC runtime has brought two of the VSTs into play, and I’ll go back through the other missing ones until I get them all in place. It may be that I copied the VST files to the laptop rather than rerunning the installers, so it’s probably my fault, sort of.

(Actually, not my fault - some of the VSTs concerned did not have the necessary runtime invoked by their installers)