Something weird with Midi, I think

Hi everyone,
I’ll try to cut to the chase but it won’t be easy:

I’m using cubase artist 10.5 and a motif xf which is my midi controller and also a sound source. Cubase treats it as a vsti. There is also an application called “Motif XF editor VST” which integrates tightly with cubase, being Yamaha and all. It’s connected by USB MiDi. Normally, when I open a project that already has the motif on a track, it takes a few minutes to load up. (they call it auto sync) Then I have access to up to 16 separate tracks from the motif.

Now the problem:
I start on the motif track and I can hear it. But if I select a different track, say audio, and then move back to the motif track, the sound drops out. The only way to get it back is to reload the whole autosync thing again.

At the same time, I was having a problem getting sound from Halion Se 3, until I happened to click on the midi reset button. That worked! But then, if I select another track and then go back to the halion track, the sound is gone again, until I click on the midi reset button again. Very much like the motif.

If that wasn’t weird enough, I also happen to have a track of loop mash. I just accidentally discovered that when I have lost the motif audio connection, if I select the loop mash track it reestablishes the audio for the motif!

I am utterly flummoxed.

Ideas anyone?


What Audio Device do you use, please? Could you try to increase the Buffer Size, please?

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

So I think I figured out the problem.
I had recently started using “cubase pro profiles” by sideshowfx. This is a product that links a ton of cubase Controls to el Gato’s streamdeck via keyboard commands and generic Remote. Apparently some of its midi settings don’t play nicely with the motif VST editor, and this was causing the glitches mentioned in my initial post. So what I did was put the generic remote settings back as they were and now it works fine. So basically I’m not using the midi part of the sideshow product, just the keyboard command part. This is fine by me. The midi is redundant anyway, at least for my purposes.

Anyone with a streamdeck thinking of purchasing sideshowfx Products for cubase, don’t let this little glitch stop you. It’s still well worth it. The problem may be particular to my set up, anyway.

1 Like