Sometimes Dorico starts as a background process but doesn't go on to open the full application

I’m using Windows 10 Pro version 20H2, with Dorico 3.5.11

A minor niggle, this can occur when attempting to open Dorico either by clicking on a Dorico project, or by clicking on the Dorico icon that I’ve pinned on the task bar. In either case, it sometimes doesn’t open the program, instead there are a few seconds of spinning beach ball and then nothing, not even the hub. When this happens Task Manager shows Dorico on the list of active background processes (but not on the list of apps), and killing it and then starting Dorico again has so far always worked.

At first I thought a previous Dorico session hadn’t closed properly, but it can happen straight after booting up, when there hasn’t been a previous Dorico session and indeed no other apps have been opened. To clarify this, I tried opening Task Manager before starting Dorico, and can confirm that on these occasions Dorico only appears as a background process after I try & start it, but then nothing else happens & the whole application doesn’t open although Dorico remains in the list of background processes.

On the other hand, Dorico starts normally about 50% of the time, but it seems completely random. On these occasions it starts off as a background process and then moves to the list of running apps when the hub opens.

It’s not that big a deal, but I guess I have a niggling fear that one day it won’t open properly even after killing the background process. That would be a really serious problem!

My guess is that this is some kind of eLicenser-related problem. Are you using the Soft-eLicenser or the USB-eLicenser? Have you updated to the latest version of eLicenser Control Center, version 6.12? If so, it might also be worth trying the previous version (available on the eLicenser download page as “previous version for support purposes”) to see whether that behaves any more or less reliably.

Daniel thank you so much for such a swift response!
I’ve done as suggested, uninstalled eLicenser Control Center 6.12 & installed 6.11 and haven’t had a problem so far (though it’s early days of course).
I use a USB -eLicenser
Happy New Year!