Sonnox DeNoiser does not render effect

Hi…

I am working on a project where I am using the Sonnox DeNoiser built in plugin. It has addressed the background noise issue beautifully.

However, when you render the file it remains unchanged. By this I mean that the resultant file is unaffected by the DeNoiser plugin: the background noise remains.

Tried this a number of times and used all the usual tricks to try and get the render to work. Without success.

In the end, the workaround was to ‘record what is played back’: a real time bounce. This worked.

The DeNoiser was the only plugin loaded, apart from dither. I also tried it without the dither … same result. The plugin was loaded in the master section.

The file was 24 bit 48 kHz stereo wave.

System is current version of WL on Windows 7 Professional.

This is a known issue back from WL7. It only happens with 24 bit files. One solution is ctrl-A-ing the file and rendering selection.

Here’s the WL7 thread about it: https://www.steinberg.net/forum/viewtopic.php?f=47&t=14635&p=248969&hilit=denoiser#p248969

Thank you for that.

I only searched the WL8 Forum before posting.

Listening to that real time bounce took me back to my Pro To*ls days.

You should activate the “Adapt” option in the plugin. Did you do this?

Thank you PG …

No. I had the Freeze button activated. This was because the offending noise was constant. Perhaps I had misread the manual on this.

The freeze button works fine on 16 bit files, just not on 24 bit. It is a bug in the plugin.

Try the selection workaround I posted above with freeze enabled.

Thanks …

I really doubt 16/24 bit can make any change. A plugin only see 32 bit float data, it ignores the original sample resolution. And unless the plugin tries to compress the freezed data (meaning 16/24 could make a difference), there can’t be a difference.

FWIW, that was my expectation PG.

there can’t be a difference.

Except there is. At least on the 64 bit Windows version. I tested this just now. Test it yourself if you don’t believe me. And remember that when you switch to the second file, you have to switch from freeze to adapt then back to freeze or else it won’t work.

With Freeze enabled…

24 bit file did not render the noise reduction
16 bit file rendered the noise reduction.

Wavelab 8.0.1 64 Bit
Windows 7

What’s important, is to be in Adapt mode when you render. It always work then, 16 or 24 bit.
I think the problem is that the “Freezed analysis” is not part of the preset, hence not transmitted when switching from the playback plugin to the rendering plugin (it’s another instance).

Thanks PG … that certainly makes sense. Logical.

I hardly ever use noise reduction (I master music) and it looks like this was operator error … I simply misread the manual.

This was a most challenging project, entirely done within WL8. It has all worked out well and the client called and told me ‘it sounds so beautiful that I started to cry’. WL8 makes people happy even when the operator may not know what they are doing!

Thank you again.