Sound distorting during playback

I’m sure the reason this is happening is because I have several tracks running multiple fx processing. How do I avoid this grainy sound during playback? Is there a simple way of saving the fx on each individual channel or some way of clearing up CPU power? I assume that’s the issue, it’s just causing my DAW to work extra hard trying to manage all these layers. Thanks for any help!

Hi,

Most probably increasing of your Audio Device Buffer Size will fix it.

Hmmmm…now I’m convinced it has nothing to do with overload of fx processing going on. I restarted my computer and opened up a blank project with 1 Midi track with zero FX and tried recording some drum beats using my keyboard as a trigger. Same issue with the distorted sound, along with choppiness(cutting out). I tried adjusting the buffer size, but as soon as I adjust it(I’m using Lexicon Omega audio interface), it resets to the lowest latency. I have no idea why that is happening. I guess I’ll have to contact the manufacturer? Here’s a screen-shot, in case this helps somehow…
Lexicon OMEGA buffering 1A.jpg

…btw, the “externally clocked” box is always checked. I had unchecked it moments before I took the screen-shot, so disregard that.

Hi,

Lexicon driver is very bad in general. I’m pretty sure, this device cannot play good with this latency.

Actually, make sure, you change the Buffer Size from Cubase: Devices > Device Setup > Lexicon ASIO Driver > Control Panel. But it might happen, even then the driver won’t work properly. In this case, you have to quit Cubase, change Buffer Size, start Cubase.

Or use ASIO4ALL instead of the Lexicon driver. You might get better result.