Sound problems - Regular Distortion

Hi! I am having sound problems with Dorico.
Usually I am using a scarlett interface without any problems. Currently I have no access to this though and I am using regular earbuds/ laptop speakers.
Every couple of minutes the sound of my playback starts distorting. I have previously bypassed this by changing the sample size, or switching from the Generic Low Latency to ASIO4ALL, and back, etc. However, recently, the distortion is not stopping from this and it is getting worse. It tends to clear out when I restart the programme. What could the issue be?
I am running NotePerformer.

I have not been able to find solutions on the forum, so I hope making this question is alright.

Welcome to the forum NBM.

With which driver and device do you have those distortions?
What are the driver settings then? Sample rate and buffer size, I mean.

NotePerformer as such should be no problem, it is quite light weight and not cpu hungry.
Have a look at the task manager, are there maybe background tasks that eat up lots of cpu power?

Also, do you use WiFi. If so, try to disable it temporarily and see if that makes a difference.

Hello Ulf, thanks for a quick reply!

On my laptop I have the Realtek High Definition Audio(SST).
Within Dorico I use ASIO4ALL and the Generic Low Latency ASIO Driver. Sample rate of Generic Low Latency ASIO Driver is 48000, buffer size small, and on ASIO4ALL either 44100 or 48000 and buffer size 512 Samples.

NotePerformer needs at least 44100, the programme tells me.
I have regularly run ableton with a 44100 sample rate through ASIO4ALL before.

My CPU usage is pretty low.
I usually only run a browser in addition to Dorico.
It still occurs with WIFI off.

Hm, looks all pretty normal then. Could you please take a video (e.g. with a smartphone) with sound, so that I can get an impression of what noise it is and how the program is behaving? Thanks

Hi! I am unable to upload something as it tells me links are not allowed (even though I am not uploading a link, but a video).
Is there a tried and trusted method that I am overlooking?

What if you zip the file before uploading?
Or you could use a service like DropBox or similar and post just the link.

If you are a new user (relatiely speaking) you will need to read a few more threads to get posting cred from attachments from the forum software. (775.1 KB)
Here you go! Sorry for the delay.

I have updated my ASIO4ALL and that works now, after setting a higher buffer size. I suppose the Generic Low Latency ASIO Driver just does not like my PC for some reason?

Edit: I am not sure whether this has worked, I am sorry, I have not done this before. Uploading a compressed video file does not work since for some reason it is read as link.

Sorry, it did not work. That what I downloaded can’t be unzipped.

On the other hand, if you have it now working with ASIO4ALL, why not just stick to that driver?
I mean, many people use ASIO4ALL, also in Cubase. There is no reason for not using it.

Sounds like buffer underruns.

Increase your buffer size.

Yes, I will stick to ASIO4ALL.
Thanks anyways for the help and time!