Sounds are loaded but Dorico doesn't fire midi to samplers

Sometimes booting up Dorico 3.5.10 on Catalina I have an issue where Dorico loads fine but won’t play any sounds.
With a template using BBCSO Core and Kontakt, Dorico loads all the samples correctly but won’t play them.
If I open up the sampler edit windows in Play, I can hit the keyboards at the bottom of of the sampler windows and the play and hear the sounds.
But Dorico won’t play them when I play the chart.

I’ve checked all the VST assigns, midi channels, Expression maps and anything else I can think of, but Dorico is just not sending midi to the samplers.
When I play the file I don’t see midi in lights blinking or the keyboard moving, as I usually do when Dorico is playing.

I’ve tried toggling the big ‘power’ button icons, both the master power at the top right of the screen and individual power buttons in the vst instruments. By the way, does that do anything? No change in any setting.

I just can’t figure out why Dorico isn’t sending midi messages into Kontakt and the BBCSO.


Hi John, when the sounds don’t get triggered, does the green play cursor in Dorico move?
If it does not move, try following: Go to Edit > Device Setup and change the sample rate to a different value, wait a couple of seconds and switch it back to the previous value. Close the dialog and try again.
In case the green line does move but no sound comes out, do the instrument’s editor windows show any incoming MIDI events? In the left top corner is an “LED” that should blink with every incoming MIDI message.

Dorico does play but there is no blinking LED showing midi hitting the samplers.
There is just no midi going between Dorico and the playback engine, none when writing or checking notes and none in playback.

Edited because…

Yesterday, it wouldn’t play. I did a full reboot as well just in case.
Today, its playing fine.

This has happened a few times before but its quite intermittent.
Its very strange and I would like to figure this out. I have a workshop in a couple of weeks at the COC here in Toronto where I was hoping to be able to do playback off of Dorico, so that I could edit on the fly. But after just blowing off a zoom meeting for the piece because I couldn’t get sound I’m a little less trustworthy of the program.

gzapper, it’s definitely worth trying the change of sample rate as Ulf suggested in his initial reply in this thread.

Sure, worth a try, but I doubt, because the trick with the sample rate usually helps in the case where the green play cursor does not move.
At gzapper, I’d also like to figure it out, please let us know if it happens again and do Help > Create Diagnostics Report. Would be even better if you could find out, under what circumstance it happens, so that we can get to the root of the problem. Thanks

It happened again today while in rehearsal. I tried resetting the sample rate, closing prefs, resetting it back to original sample rate. Unfortunately that didn’t help either. And to confirm, the green playhead moves the weird thing is that the ‘led’ midi indicator lights in the sound banks/BBSCO/Kontakt files don’t light up like they are getting midi from Dorico.

I did a full reboot eventually and that cleared it up.

Oh, and gotta say I’m loving working with the new BBCSO templates. I built my own but these are much nicer, the double dynamic controls gives it much more dynamics in general. I’m still on a 2016 macbook pro, so stuck to 16 gig RAM, but it mostly runs. I have to close all other programs, in some ways it reminds me a bit of working off of laptops about 10 years ago where I was always maxing it out. Dorico will skip notes and stutter, but mostly play it fine. This using BBSCO in core mode. I really have to either get a mac mini for sample playback or try to afford a new macbook pro with the RAM maxed out.