Sounds are not saved in some vst plugins, even when disabling program change in vst

With some vst plugins the selected sound is not saved.
When loading the project the sound is going to the first sound.
Also when disabling the program change in the vst plugin itself the first sound is still loading

Name a few pls?

Program Change (in Layer) is independent from what the plugin saves and it highly depends on the plugin how it handles this. So please let us know what plugins you are talking about or name at least one.

predator 1 and 2 ( Rob Papen )
Linplug Albino 3
and some other plugins.

Thanks, we will check. We did fix a bug (next version) that might be related.

All of these are not available anymore. Are all of them VST2 maybe?
And as those are all Rob Papen plugins, I tried Go 2 and I can change cutoff or anything, save and load again and it has remebered those settings as expected.
Let us know if it only happens with VST2 plugins, and/or other plugins that expose this problem for you.

I did installed Go 2 , vst 2 and vst 3
With the VST 2 version , the settings are gone, with the VST 3 version all settings are saved
So you are probably right this happens only with the VST 2 plugins
I’m using more VST 2 plugins but ( most of them ) are working fine.
Greetings, Albert

We’ll try to find a case to reproduce, thanks.

So I tried Go2 VST2 version. It works fine and presets are stored and recalled as it should. But when loading the project, it loads something like “unsaved prest xxx” and no sound. We’ll investigate further. Workaround is to manually load the preset, at least it keeps it when changing Parts or Songs.

Yes exactly the same when i load the project file.
And this happens also with some other plugins such as predator and predator 2
Greetings, Albert