Sounds Missing From Library

Hi @student.test ,
If you get permission denied error, try the following:
In the Terminal window type

sudo ./

You will then get prompted to type in your password. After that the script should run fine and create the zip file on your desktop.

And in regards to your license issue, I’ll ping Ben again.

Thanks @Ulf
I’ll try to get the student again during recess/lunch today, if not I’ll have to catch him next week.

Hi @Ulf I`m now getting the error:
“sudo: ./ Command not found”
Any idea regarding this.

And any way of solving the issue regarding the 2 windows machines?

The dot and slash at the beginning of the command line means the current directory. The error means the shell script was not found at that location. You can type cd ~/Downloads [enter] to make sure you’re pointing to the right directory. (The tilde ~ and slash means your Home folder.)

Were you able to do the other steps of Ulf’s procedure without errors?

1 Like

@Mark_Johnson Everything else up to the error, though I`ll check with the student next lesson to see if I can actually get the diagnostics report to work.
Thanks for the advice though.

With the commands in the Terminal window it is important that everything is 100% correctly written. Looking at the error message, behind the sudo is a colon character that shall not be there. Please pay attention on every detail.

Hi Ulf. I tried pasting your UNIX code into my terminal and this is the result:

You will note that the colon in question is only present in the ‘command not found’ line.

In that screenshot you appear to be pointing at the home folder (~), which is probably not where the script is located. First do cd Downloads again so that the prompt ends with “Downloads %” and then you should be able to run the script.

I’m pointing out that Ulf’s directive as stated by him doesn’t work and that the error reported by @student.test showing the colon after the sudo command results AFTER the correct (as per ULF) UNIX command is entered into the terminal window.

As to your directive to change directories (cd Downloads) I get the following:

That was my instruction in an earlier post, so it was correct there without the colon.

That the ‘command not found’ message comes has most likely to do with the fact that that shell script has no execution privilege, yet. That’s why one has to do that chmode +x

I’m also happy to provide help via remote screen sharing, if wanted.

Yes, you see there the prompt says “Downloads %” instead of “~ %” so you could then issue the sudo etc. command.

What I’m taking from this is that it may not actually work anymore?
I’ll Try once more but thanks for showing me that you are getting the same error.

If anyone knows how to fix the halion sonic Files missing error on windows please let me know As we have 2 windows devices getting the same error

As to your particular problem, I don’t know. Sorry.

is ‘chmode’ a Windows ‘unix’ command? It doesn’t appear to be a Mac OS command:

Probably meant to be chmod (not chmode), as in one of Ulf’s earlier posts in this thread.

For All those wondering, We have not found a fix to this issue for our devices (1x Mac + 2x Win11), rather we finally got a our Dorico Pro 4 Licences and Found that they just work.
So we`ve put our students having issues (all windows users have the issue) onto our few Dorico Pro 4 Licences, I can still attempt to troubleshoot for Dorico 3/3.5 but there isn’t a reason for us to worry about it.

I’m sorry and apologize, indeed there was a typo, instead of chmode it must be chmod