Soundtoys Native Effects and jBridge - Crashes

Hi there!
I just bought Soundtoys Native Effects and, knowing that the built in bit bridge in Cubase is not all that stellar, had them bridged via jBridge (1.5). Still I can´t seem to get them to work reliably. I keep getting BSODs or jBridge reporting that “the plugin may have crashed”. All drivers are up-to-date (including iLok), RAM is good, system running fine as long as I´m not using those bridged Soundtoys plugins (which are the only bridged plugins here, btw. Everything else is 64bit).
Cubase doesn´t see the “unbridged” original 32bit folder, so I can rule this out, too.

Are there any specific settings in jBridge that anyone can recommend with Soundtoys specifically?
I tried the forum search but couldn´t find any hint so far.
System specs are down there in my signature.
Many thanks in advance…

I had the same problem, never managed to solve the issue. I think it’s because of the ilok. I just don’t bridge soundtoys plugins and i stay with cubase 32 bits for now…

is it an ilok 1 or 2?

Ive used the soundtoys stuff with the cubase bridge with no problems

I would suggest trying out the DAW Reaper and rewire it into Cubase. This solution has solved a lot of problems with 3. party 32 bit plugs in CB7 for me. The trial is free and if it works for you it only costs 60USD to buy (certain rules apply).

It is of course a little more hassle but at least you get to use your favorite plugs. I use this solution on plugs that are not supported anymore thus there will never be a 64 bit version. BTW I use the 64 bit version of Reaper and all my 32 bit plugs work well inside it. I am a little bit puzzled why Reaper handles this well but not CB and Logic.

Not entirely related but does concern a Sound Toys plugin:

I got the Little Micro Shift plugin and it shows up in C6.5 (and seems to work fine) but does not show up at all in C7. (All VST paths are correct etc). Very strange.

I must add that I am using the C7 demo. (So far I am wondering why I should upgrade at all… Not too impressed with stability etc and there are even features missing from 6.5! :astonished: )


Devil Loc / Little Radiator / Radiator / Little Microshift with Cubase 7 Bridge OK

Are you by any chance using an iLok type 1? If yes, there’s your answer: iLok 1 is NOT compatible with Cubase 7, as Steinberg repeatedly claimed. I had three of those and despite the Steinberg warning I tried to use them, to see if they worked. Well, sometimes they did, but they often crashed. So, I bought a single type 2 (which can hold up to 500+ licenses) and compacted all my licenses onto a single iLok. Something I should have done long time ago… :wink:

P.S. Sorry I don’t use Soundtoys products, so I cannot assure you that they’d work on my system.

Using Jbridge, Ilock 1 with little radiator and little microshift with no problems here. Also use some Izotope products with ILock 1 as well…