Space before key signature for invisible clef?

In this example, I’m using an invisible clef and trying to create space before the key signature, but I can’t seem to get it to work with the spacing options. Any ideas?

Doe the invisible clef actually have some width itself?

How about this?


I edited the 12-EDO tonality system and added a new accidental with pitch delta -1 and two glyphs: staff1Line (U+E010) with Y set to -8.00 and Color set to #ffffff, and accidentalFlat (U+E260). I then created a custom key signature with the new accidental on the middle staff line and applied it where needed.


Are you planning to add a custom clef later?

That, I don’t know. It doesn’t seem to. I was hoping the standard spacing options in Engraving Options would do the trick, but alas.

No, planning on leaving this clef-less, since it’s a cleaner look for pages and pages of chant.

@johnkprice that works, but oy veh!

1 Like

Another possibility would be to create an invisible clef with some width to it. Take a clef you aren’t using, like Treble Clef 8 Above, and use the Edit Music Symbol dialog to replace that clef with staff1Line (U+E010) with X and Y Scale set to 50.00 so the glyph is hiding in the middle staff line.