Spacing a bit off after adding a new note to a dotted chord

[raw beginner alert]
I had a dotted chord, and the spacing between that chord and the notes in the next beat was fine. I then added another note to the first chord, one of which was in an adjacent line, which of course causes the width of the chord to widen, because it shows the two notes that are close together slightly spread, horizontally. However, Dorico did not shift all the later notes in the measure across to make room for the slightly wider chord, and the dots are now too close to the notes in the next beat.
Is this a small bug? Having Elements, I believe my options for fixing this manually are limited - yes?

Difficult to say for sure without seeing it. Dorico’s auto-spacing algorithms are generally good at avoiding collisions, though there are odd little exceptions. What’s your note spacing set to? Layout Options—Note Spacing.

I’ve attached a simple project. I’ve started to read up on the Note Spacing options, and tinkered a bit, but haven’t been able to fix it. The problem isn’t specifically related to adding notes to already existing chords - that’s a red herring. It’s just a simple spacing issue.
In the attached, I want the second beat to be moved a bit to the right, further away from the dots.
EDIT: I’ve added a screen grab. (366 KB)

In the specific example shown in your picture, there’s no horizontal justification going on. Once you’ve added sufficient music that the width of the system is at least 50% full (or whatever value you have defined on the Note Spacing page of Layout Options), the music will be justified and that gap will open up.

Thanks Daniel. I’ll go and read up on justification, but I am using Galley View, so right now, I don’t understand how & why “justification” should be a factor. Why should Dorico EVER place that second beat so close to the dots? Why isn’t there a minimum spacing that Dorico honours, so this situation never arises?

I’m not sure you should expect finished layout spacing in Galley mode. There are a number of differences (spacing between staves with multiple lyric verses has been mentioned) where Galley view does not redraw according to Page View rules.

I am not expecting “finished layout quality” in Galley View. I am just struggling to understand why Dorico would ever produce this appearance at all, in Galley View, where one is supposed to be concentrating on the musical content, without regard to layout. It looks silly. In my simple one bar example, what other thing is Dorico deciding is so important, that it has to bunch up the notes like that?

I think you are worrying too much about the wrong thing in Galley Mode, which is just meant for inputting music quickly.

Part of inputting notes is checking that’s what’s been entered is as intended. I am waiting for an explanation of why Dorico reduces readability by placing the notes so close together. It moves the notes around all the time as edits are made, so why doesn’t it move them appropriately in this specific case?
I am still of the view that this is a bug. (a very minor one)

Btw, I’ve just encountered another, similar situation - ties were being displayed as tiny little “carets”, with straight edges. As a novice, I was VERY confused. All of a sudden, when I made a very minor edit to the same bar, the notes moved apart, and the ties were rendered normally. I did not add any new bars - all I did was move one note from one stave to the other, which triggered a positive reformat. I simply don’t understand what was preventing Dorico from displaying the ties properly from the outset. It appears to me that Dorico, just perhaps, could do with a bit of improvement in the area of formatting, when in the “pre-justified” state.

In galley view the music is never justified, in fact, so you will always see the default minimal spacing values, i.e. whatever the ideal spacing gap is for that duration according to the options on the Note Spacing page of Layout Options, plus whatever distance is required to eliminate any collisions between successive items and maintain the minimum required distance between them. Dorico measures the required distance from the left-hand side of the notehead on the normal side of the stem (i.e. discounting back notes, which are considered by the spacing calculation for the previous pair of successive notes as something that might cause a collision), so rhythm dots to the right of noteheads themselves are not accounted for explicitly; the fact that the note is dotted and thus has a longer duration than an undotted note with the same written value is sufficient to allocate a bit more space to that note.

So a successive note can follow pretty close to the rhythm dot of a previous note, sometimes even to the point that the gap between the note and its rhythm dot is larger than the gap between the rhythm dot and the successive note. However, because the gap between the notehead and its own rhythm dot is not justified and the gap between one note and the next rhythmic position is justified, normally what happens is that the gap ends up larger via justification. But in galley view, because there’s no justification, this doesn’t happen.

Let me stress, however, that this is all as it should be, and this approach is crucial to the way that Dorico is able to produce note spacing of beautiful clarity and proportion. But it will only look as good as possible when it can be justified, and that requires page view.

If you want to change things a bit in galley view, you could increase the ideal spacing gap for a quarter note from 4 spaces to, say, 5 spaces in the Note Spacing page of Layout Options, but don’t forget to change it back when you’re ready to start looking at page layout and are thinking about printing out your music.

I remain completely unconvinced that it needs to behave like this, and I fail to understand why “justification” is even mentioned in Galley View. It is purely a minimum spacing issue - yes? Thanks for the suggested workaround. If it works, why can’t Dorico do this for me automatically? I.e - have a more legible minimum spacing in Galley View, and automatically display it better in Page View?

Personally, I treat the default spacing gap being 4 only in the sense that the default has to be “something”. There is nothing magical about 4. Sometimes it is much to wide, sometimes much to narrow.

Out of curiosity, I tried Musescore. It’s no better. Hmmpph.