Spacing problem. HELP

2nd Post for today. Sorry to bother you!

I’m having a really hard time here learning Dorico coming form Finale.
I attached a file of my arrangement that’s a big mess with spacing. What happened en how can I tell Dorico to auto space the staves so there are no collisions?
In the tutorials it says It’ll auto space but that’s not what is happening here. Probably I did something wrong.

Thanks for your help again!

You have too much material for the vertical page space provided. Dorico does indeed space beautifully, but it can only work with what it’s given. Try reducing your space size slightly in Layout Options—Page Setup. You could also try reducing the minimum distance between staff items in Layout Options—Vertical Spacing.