Specific midi notes hanging, not turning off

Strange thing has happened. I use NI Komplete kontrol S61 midi keyboard with Cubase. No problem for years. Now suddenly G3 and Ab4 notes are hanging when played. All other notes are fine. When recorded they record long notes as well and also play back that way.

  1. When I transpose the pitch up and down still the same notes (G3 and Ab4 ) hangs no matter where
    they are moved to. So assume not a problem with physical keys.
  2. I tried the same set up with Logic Pro then problem goes away.
  3. When you press these notes several times it appears to loop layer after layer.
  4. Change the USB ports still no luck.

Please could somebody help me with this annoying issue.

Many thanks.

Harsha

Cubase 11
Macbook pro Catalina
NI Komplete kontrol S61

Start with this:

  1. Create a MIDI Track and route your S61 to its MIDI In
  2. Put a MIDI Monitor on a MIDI Insert in the Track’s Inspector

Now when you play/release a G3 you can see what is being sent.

1 Like

Ok I will try and see
Thanks

Ok I have done it. Please see the image. G3 and Ab4 are not sending midi off notes.
In Logic pro same keyboard send said midi notes

It is Cubase but I don’t know how to fix it

Please kindly advise
Many thanks in advance
Screenshot 2022-03-01 at 11.12.21

To add to this
When use a midi monitor on mac with the keyboard, it sends midi on and off accurately . So it is not the system or the keyboard.
Have a look in the image . Thanks

Harsha

Yeah that’s the next debugging step. So it looks like something is changing the MIDI Data. Things that potentially could be doing that are the Input Transformer, Expression Maps, and maybe Drum Maps.

Does this happen for every Project or only specific ones? If you create a new blank Project and then add a new MIDI Track does it happen with that.

Can you post a screenshot of Studio>Studio Setup>MIDI Port Setup

1 Like

Thanks
Thats something I didn’t check actually.
I will set up a blank project tomorrow and let you know. Also will send the midi setup as well
Thanks for your continues support
Harsha

Also, if the black project doesn’t answer it, Check on Virtual MIDI Ports and the MIDI setup in the Utilities on the Mac. This one is fresh in my head for… reasons.

MIDI can be routed around the machine before it ever makes it to Cubase, and sometimes people try things out that they then forget about for weeks.

1 Like

Hi guys
When I tried cubase on safe mode it worked.
So deleted the preference file and rebuilt it
All started working with that

Thank you both for your help

Harsha

1 Like