SpectraLayers 11 - ARA problem

Dear all,

Yesterday ik upgraded fom SL10 to SL11.
In StandAlone mode it is really fantastic and without problems.
But when I use it as an ARA-plugin the interface doesn’t draw the spectral image and wafeform. This happens both in Wavelab Pro 12.0.20 as in Cubase Pro 13.0.41.
Applying edits in SL11 does work but no image …
I’m on Windows 10.
Am I doing something wrong here?


Could be a graphic driver issue - can you copy/paste what you see when in ARA mode and clicking (SpectraLayers menu) Help > Support Info > Log Output ?

21:13:20.210 42a4 INFO C:\Program Files\Steinberg\SpectraLayers 11\Win64\SpectraLayers.dll -platform windows:nowmpointer
21:13:20.211 42a4 INFO auto-detected folder: C:\Program Files\Steinberg\SpectraLayers 11\Win64
21:13:20.842 42a4 INFO early init done
21:13:20.848 42a4 INFO creating app…
21:13:20.856 42a4 INFO loading properties…
21:13:21.173 42a4 INFO session SpectraLayers 2024.06.20-21.13.20.209 started - embedded
21:13:21.173 42a4 INFO SpectraLayers Pro 11.0.0 Build 363 (x86_64 - Qt 6.6.3 - qtnamespace: SpectraLayers - MSVC 1929)
21:13:21.176 42a4 INFO OS: Windows 10 Version 22H2 (Kernel: 10.0.19045) (nl_NL)
21:13:21.176 42a4 INFO CPU: 16 threads (AVX2)
21:13:21.176 42a4 INFO RAM: 32 GB
21:13:21.176 42a4 INFO HDD: 476 GB (229 GB free)
21:13:21.176 42a4 INFO SCR0: 2560x1080x32@60Hz (device pixel ratio: 1) (primary)
21:13:21.176 42a4 INFO creating window…
21:13:21.184 42a4 INFO loading plugins…
21:13:21.618 42a4 INFO 40 external plugins loaded
21:13:21.629 42a4 INFO initializing UI…
21:13:21.670 42a4 INFO libpng warning: iCCP: known incorrect sRGB profile
21:13:21.728 42a4 INFO layout and graphic objects initialized
21:13:21.764 42a4 INFO setting shortcuts and properties
21:13:22.198 42a4 INFO UI initialized
21:13:22.212 42a4 INFO Ready
21:13:22.225 42a4 INFO Host: Cubase
21:13:22.226 42a4 INFO Host: Cubase
21:13:22.226 42a4 INFO Host: Cubase
21:13:22.595 42a4 INFO creating external project SamplingFormat(Real, 44100Hz, Audio, 2 channel(s), mapping: 11)
21:13:22.597 42a4 INFO activating external project SamplingFormat(Real, 44100Hz, Audio, 2 channel(s), mapping: 11)
21:13:22.670 42a4 INFO Show (0x40794)
21:13:22.863 42a4 WARNING OpenType support missing for “Open Sans”, script 11
21:13:22.864 42a4 WARNING OpenType support missing for “Tahoma”, script 11
21:13:22.865 42a4 WARNING OpenType support missing for “Arial”, script 11
21:13:22.866 42a4 WARNING OpenType support missing for “MS UI Gothic”, script 11
21:13:22.867 42a4 WARNING OpenType support missing for “SimSun”, script 11
21:13:22.867 42a4 WARNING OpenType support missing for “Segoe UI Emoji”, script 11
21:13:22.869 42a4 WARNING OpenType support missing for “Segoe UI Symbol”, script 11
21:13:22.971 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:22.971 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:22.971 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:22.972 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.036 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.036 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.037 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.037 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.038 42a4 INFO activating external project SamplingFormat(Real, 44100Hz, Audio, 2 channel(s), mapping: 11)
21:13:23.073 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.083 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.189 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.189 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.202 42a4 INFO activating external project SamplingFormat(Real, 44100Hz, Audio, 2 channel(s), mapping: 11)
21:13:23.205 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.205 42a4 WARNING The top-level window is not using OpenGL for composition, ‘D3D11’ is not compatible with QOpenGLWidget
21:13:23.259 499c INFO internet access:true
21:13:27.322 42a4 WARNING QWidgetWindow(0x911a4770, name=“QEmbeddedClassWindow”) must be a top level window.
21:13:27.343 42a4 WARNING QWidgetWindow(0x911a4770, name=“QEmbeddedClassWindow”) must be a top level window.
21:13:30.488 42a4 WARNING QWidgetWindow(0x911a4770, name=“QEmbeddedClassWindow”) must be a top level window.
21:13:30.512 42a4 WARNING QWidgetWindow(0x911a4770, name=“QEmbeddedClassWindow”) must be a top level window.

I had the exact same entry.

21:13:21.670 42a4 INFO libpng warning: iCCP: known incorrect sRGB profile

Try updating the graphics drivers; I was able to resolve it that way. I hope this helps you too.

1 Like

Just a tip: to quickly find outdated drivers, I used this app, and it worked immediately. DriverIdentifier - The most simple & easy driver updating tool.

1 Like

Thanks for your sugggestions Stefano!
I got a massive graphics drive update from DriverIdentifier but unfortunately it did not solve my problem …

If I use the new Tranfer Tool all graphic disappears in the moment I click.
Does anyone else have the same problem?

Yes, it disappears for 1-2 seconds. Also the tool itself moves in a sluggish and unpredictable way, making it very hard to use. ARA, Mac M1.

Hi there,
are you using on your system a build in graphic device or / and also an external GPU device for example on Win 10/11 an intel UHD Graphics device together with an GPU device which are then primary used or not used for the applications ?
If so, please also try to update the intern graphic chipsets beside the GPU driver update procedure.

Thanks a lot for your infos.

Cheers
Kay

1 Like

I updated every driver and there is still this problem…

Cheers Edwin

I have the exact same problem. Don’t know what to do…

@Edwin @Stefano7 @geab86 can you try build 372 ? This should hopefully fix all graphic conflicts issue.

Hi, it worked! Thanks

@Robin_Lobel I have tested build 372 as a standalone, with ARA in Cubase Pro 13 and WaveLab Pro 12 on Windows 10, everything is perfect so far. Thank you.