Spectralayers stretching my audio

I have my song coming out a 44 bars. After importing into spectralayers and then exporting back into my daw my tracks are now 10 bars longer. Any ideas?

I’ve checked sample rate, buffer size. I froze and flattened my tracks. Tempo is the same. I dont see how this is possible.

Did it begin as a tempo match sample in the DAW. ie time stretch to bpm?

Im not really sure what you mean. Its Ableton for the DAW. If I locate my sample and bring it into Spectralayers and then back into my DAW its stretched. Ableton does have its warp feature that I’m not real familiar with.

Ahh ok. Some samples have the bpm set in the file metadata so the DAW knows how much to stretch them to fit your session bpm automagically. I’m not sure in Ableton, but in Bitwig there’s some system behaviour settings to control how you want samples to behave when importing/exporting/bouncing. I typically work with raw samples at the sample rate if it’s going backwards and forwards to 3rd party tools, so no stretching or bpm matching is messing with the file, but it all depends on your needs I guess. You could always bounce the track and then use that in Ableton. Do you have system settings such as: