Spectrogram edit view slow

I’m having a problem with the spectrum edit view being really slow to respond and super laggy for zooming in and out (vertically and horizontally). Scrolling forwards and backwards is slow and very jerky too. No problems with lag anywhere else in WL 12. This doesn’t happen on my MacBook Air running WL 12 (M2 16 GB RAM) so I’m guessing it’s something specific to my Mac Studio (M1 Ultra 64 GB RAM) install. The spectrum edit in WL 11 on the Mac Studio works perfectly. Any thoughts on what I’m missing?

Hi!

Do you work with big files?
I have tested here with my MacBook Air M1 8 GB from 2020 with MacOS Ventura
2 min or 7-8 min files and zooming is very fast with spectrogram
both with shortcut or with mouse.
Can it be MacOS related?

regards S-EH

Thanks! It seams to be slow on any size file, even a 2 min 44.1/16 wav. I know that something is off on my system because the spectrum behavior is fine on my MacBook Air and my assistant engineer’s MacBook Pro. I just can’t figure out what’s happening on my Mac Studio. Maybe some kind of cacheing issue?

There are two spectrum view: “spectrogram” and “wavelet”. The latter is much slower because requires many computations. Maybe you selected “wavelet” and not “spectrogram” ?

Good thought, but no, I’m using the spectrogram tab. It’s weird that WL11’s spectrogram view works flawlessly but WL12’s spectrogram is acting strange on the same computer. Makes me think I’m missing something in the preferences of WL12.

The only settings that could have an influence on the speed, are the following ones.
Try to use these default settings.
Other than that, I must say I have no clue. The speed is bounded by the CPU and your machine is capable.

image