Spectrum Display in Channel Settings

Is there a preference for this?
It doesn’t seem to work unless I have something in the inserts, even when the EQ is on.

Update. It appears that if you have the track playing when you open the channel settings window (e) the spectum display always works. If you open the window with the transport stopped, it seems to be hit or miss.