Spectrum Editing: Surgery vs Master Section: Routing issue?


I’ve not found anything in great detail online that helps here. But then again, google often fails me.

I’ve been using Spectrum Editing ‘Surgery’ mode for years, and when I need that function, it’s fantastic. But I’ve never used (much less fully understood) the function of sending Spectrum Edit selections through the master section. So now I have WL9, and I’m learning some new things, and here I am.

When I have selected “Spectrum” in the wave window (the tab at the bottom of the wave window) and then select ‘Master Section’ in the spectrum editor, I can see that there are separate routing options for selected and non-selected spectral regions. WL9 seems to be able to route spectrum selections through the master section, while leaving non-selected audio untouched by the master section, or vice-versa. So, let’s assume I select “Bypass”. This means that any audio selection, or audio in a non-selected region in the Spectrum window bypasses the master section completely. This could be extremely helpful in ‘notching out’ certain narrow-band noises. Seems wonderful.

However, when I experiment with using spectrum editing via ‘master section’ and the various routing options (via clicking the ‘render’ button in the spectrum editing window) I don’t get what I expect. Whether a selection is sent to Bypass, Input, or Output, the result seems to be unaffected by the master section - there seems to be no difference between selected region and non-selected region. It just seems broken to me.

So after HOURS of experimenting with this - as far as I can see, there appears to be an issue with the routing for the Master Section when the 'Spectrum" tab is selected in the Wave window (At the bottom - the Wave-Spectrum-Level tabs) Routing works OK when the Wave or Loudness view is selected, but while viewing the spectrum of the wave file, the audio does not seem to route to the master selection at all. In fact, if I enable or bypass the master section at this point, there’s no difference in the audio - Even the master gain faders do nothing if the section is bypassed or not. If I’m viewing the wave file or the loudness, then the master section works OK. So yes I’m terrifically confused. Clearly, I just don’t understand. I can’t get the spectrum editing through the master section working at all.

Is there something broken? Am I missing something? How is Spectrum Editing through the Master Section supposed to function normally?

Thanks in advance!

EDIT: I think it’s working. That is to say, I was able to find a selection routing options that allowed me to perform some manner of spectrum editing via Master Section. It does not provide the same degree of damping, but it’s a heck of a lot easier than going through 75 minutes of live music and damping 30 seconds at a time.

Still learning, thanks.

I will check this later this week.