Spectrum Editor Stuttering Playback

I’m getting stuttering playback in the spectrum editor when Mute Selection playback is selected. Also it doesn’t stop stuttering when I switch it back to Normal playback. I have to remove the selection in order for it to stop stuttering. Win 10.

I guess look and see what is running in the background of your computer. Not sure if you have a PC or Mac. But I am sure you know how to look at the processes currently running in either one. After my problems with AVAST recently I am starting to check more often what ELSE is running that I don’t know about. A couple of programs that I recently upgraded (that are NOT audio related) have been doing POPUPS on my screen telling me to upgrade or reminding me of something. Programmers these days are also putting in “bots” that report back to the software company. Lots going on that you may not be aware of. FWIW

Hi Bob …

If your machine has done a recent Windows update … check your sound card settings.

The last big update somehow reset my RME card to a 256 buffer which … in your case … could produce something like you are experiencing.

Thanks Rat and Thomas, all looks normal.

The thing is I’m getting it on two different systems, desktop (stuttering) and notebook (flanging, I’d say), and it seems specifically related to a selection in the spectrum. If I make a relatively small rectangular selection in a whole full length song file, for one thing, it takes forever to go into Play, and when it does the playback is stuttering or flanging. Especially if I select Mute Selection Playback. I’ll try it again with a sweep test signal to confirm the flanging, but if someone could try it, I’d appreciate it.

If the selection is removed all is normal.

But I’d really like to use the Mute Selection Playback.


Short or long mute selection?

regards S-EH

Can you try both? The last I tried was probably about 15 seconds long in a 5 minute song, covering maybe a 1500 hz range. Because the flanging was kind of subtle (but the stuttering’s not), the most obvious thing to me was the 6-7 second delay before play start if doing it in a full length song file. Normally I use the spectrum on very short segments I’ve made, but when I tried adding a selection like this to a full length file, the time to start was VERY long.

Yes will do I’m on OS X 10.11.6 and WL 9.5.40 (build 180)
I will report back soon :slight_smile:

regards S-EH

Thanks S-EH. With these playback stuttering/flanging issues it was hard to tell what the Mute Selection was doing, if anything, but it appears, behind the playback issues, that it’s also doing nothing at all. If you select a wide frequency range, you can easily tell that range is not being muted. (with Spectrum/Playback/Mute Selection selected). And if there is a selection, and Mute Selection is selected, the audio definitely sounds wrong (flanged) and there are higher meter peaks. Seems like a bug, unless there’s some weird conflict on my machines.

Solo Selection playback seems to work ok.

Thanks again for the offer S-EH, but I seem to have it working now. I had to reset my settings (by renaming the settings folder), so new settings were created, and now it seems to work correctly. I’ll do the same on the other system when I have a chance. Strange that basically the same exact problem (solo selection works, mute selection doesn’t work and causes playback problems) would happen on two completely unrelated systems.


Yes I have been trying out with the Spectrum Editor and I can’t make it misbehave
and I been trying with very short sample(s) like 50 ms, 1. 2, 5, 10 and more seconds
and it works fine here with Built in Audio Device and RME Fireface 800 from 2004 !

and thank you Bob for taking your time with this and sharing the Preferences stuff
good tip to know about for all WL users!

regards S-EH