Spectrum Editor + workflow

Hi, I’m not at all new to Wavelab but have come to feel like an absolute fool when working in the spectrum editor. Let me explain:

  • I copy + paste a spectral selection to remove unwanted noise - working
  • I listen to the result - working
  • not happy with the result I undo - working
  • I try to make a new selection - not possible
  • I click into the ruler/set cursor to start playback from that position - file plays from the start
  • I change to wave view to get me some control over the transport - find me zoomed into the very end of the file
  • I open the spectrum editor to do another single operation - only one edit at a time possible, the same show starts again

Can’t imagine, this the intented behaviour, is it?

Hi marQs …

I have experienced this behavior.

Have a look at this topic: http://www.steinberg.net/forum/viewtopic.php?f=47&t=612

Does it mirror your experiences?

For me, this behavior is not repeatable and only occurs intermittently. The workaround that works for me is to switch back to the waveform display to playback.

Hi Rat,

yes, that’s exactly what’s happening. I also found the ruler showing a place in time far beyond the file length.

The workaround I’ve found yesterday was to loop some seconds around the spot I’d like to edit, do my operations in the spectrum editor (while playback), change back to waveform, deselect (releasing the loop) and go through the whole track that way.
Works well as long as I don’t toggle between the two modes of the spectrum editor. In this case the trouble starts again 1 of 2 times.

PG, any news on this issue?

Twice I met myself some more or less similar issue. So yes, there must be some problem somewhere. I note this as high priority for next update.
But if you have some 100% reproducable step by step procedure, please tell me.

This has been driving me nuts! I’m so glad you’re onto this PG, can’t wait for the next update.

gg

Nice to hear, PG!

Have been trying to create a bulletproof repro scenario - think we have to take different settings and starting points into consideration. Pre-/postroll + zoom level seem to create some internal confusion:

Scene # 1: zoom level: complete file displayed, pre-/postroll set to x seconds.

  1. Do edits in spectrum editor.

  2. Hit play.
    Result: everything’s fine. Spectrum editor still works, further edits possible.


    Scene # 2: zoom level set to show a few seconds of file, pre-/postroll set to x seconds.

  3. Do edits in spectrum editor.

  4. Hit play.
    You see the cursor going through the pre-/postroll area and hear the edit you’ve done properly.

  5. Hit play again!
    You hear the pre-/postroll area, but you won’t see the cursor going through it!

  6. Try to use the arrow tool to make a new selection.
    Result: previous selection disappears (what it should), a new selection not possible!

  7. Hit play once more.
    File plays from beginning.

  8. Zoom out to see more (or toggle to waveform display)
    You’ll find the cursor way beyond the end of the file. Wavelab allows you to make new spectral selctions again!


    Scene # 3: zoom level indifferent, pre-/postroll set to 0 seconds!

  9. Do whatever you want in spectrum editor.

  10. Hit start/stop as often as you want.

  11. Make and release loops as if you’ve get paid for only that.

  12. Zoom in and out like there’s no tomorrow.

Result: everything’s working absolutely great and as it should!

Please try to reproduce. The behaviour described has happened everytime here the last hour while I was composing this post/re-checking to confirm my own claims.
Well, now that I know, it is working for me when I simply don’t use pre-/postroll, I’m pretty set. Gets me back to get my work done.

Thanks for reading, this was a long one…

marQs

PG …

As advised previously, I am not able to reproduce the error. My experience still appears to be completely random.

Given that I’m mastering records every day, if you have something you want me to try I am happy to do so.

@marQs:
Thanks for the details. I could produce something with your explanations. I can’t work on this issue now, but it’s on my priority list for next update.

Philippe

I had occasion to use the spectrum editor last night, and I pretty much gave up on doing anything subtle, as it gave me so much trouble.

Edit, double-click to play, repeat, repeat, then the next time the play position jumps to the start of the file and the upper display jumps in the other direction to a different point. This has to be a WaveLab 7 problem, rather than something else, and wasted a lot of time.

Using undo caused all sorts of problem - the spectrum was not refreshed, and sometime hung so that I couldn’t play, or scroll, or anything. Random fiddling got it back (and the undo had worked). This could be a display driver problem I suppose. I haven’t tried looking for an update yet; but I made this (Windows 7 x64) machine barely six months ago, using a low-end video card (no fan) from a major manufacturer (Asus, like the motherboard), and there is no comparable issue in any other program whatever.

Paul

Thanks for all that work marQs!

I’m going to try your fix and see if it works on my machine. If it does I’ll be eternally grateful.

Gary

Well, that’s service ‘deluxe’! Thanks a lot, PG :smiley:

MarQs solution works on my system. As promised, I am eternally grateful.

Thanks MarQs!

gary

I’m new to WL7 and have been having a lot of trouble with the spectrum editor. Nothing I’ve tried has fixed it. Here’s a quick movie of what’s going on.
wavelab spectrum bug.mov (854 KB)
As you can see, I’ve got a fairly long file of individual samples. I press the spacebar and the selection plays (I’ve got my transport start option set to Selection start and my end option set to Selection end). I press command-2 to get to the spectrum editor and press the spacebar again and the selection plays. At about 7 seconds in, I press s to get the spectrum editing tool and select a louder area that I want to reduce in volume. Now, this is where things first start to get weird. When I press F6 to play the selection - WL plays the old selection. Not only does it ignore the time selection I’ve made, it plays back the entire frequency range. I would expect to hear only the time and frequency selection that I just made. I’m assuming this is a bug, but if it isn’t, I’d like to request that time and frequency selections in the spectrum editor are what I hear when I press F6 to play the selection.

Things really get strange at 19 seconds in. I press the spacebar and it should play the selection again, since this is how I have my play start/end settings setup, but instead, the cursor jumps to some random place previous to my selection. I have the pre-roll set to 0, so this can’t be the issue. At 23 seconds, I attempt to make a change in the selection, but look what happens. There’s no longer any way for me to make a normal selection because WL thinks the beginning of the selection is the beginning of the file.

At 32 seconds I hit command-1 to go back to the wave view, but as you see, it now appears that the file is empty, even though you can see the selection is still in place in the overview. But, in the main window, the scroll button is to the far right - as if I’m at the end of the file. But in fact, it seems as if I’m in some imaginary place that exists beyond the end of the file, since there isn’t any silence in this file. The only way to get back quickly is to press K to view the present selection.

This is the bug that I encounter almost every time I use the spectrum editor. I really want to use it more, but it causes so much trouble, that it currently isn’t worth using. Is there some fix in the works for this?

OSX 10.6.8
WL 7.11 (550)

This issue is fixed in next update.

Fabulous!

Thanks Philippe.

I have just recently been using the spectrum editor in WL7 and have also experienced the behaviour described (cursor jumping, not being able to select more than once etc), so I’m really happy that it’s being fixed. Thankfully my current project has a pretty long time frame (a few months), but it features an insane amount of edits such as these. So, any ETA on the 7.2 (or other)? In the meantime I’ll try the workaround.

Thanks,
j,