Spelling and accidentals problem

In a piece I’m currently notating into Dorico from scratch - when I have intervals of an augmented second, in this instance a Db - E I like to put a natural in front of the E, but I can hit the zero key all I want and get no accidental. I know I can close the caret and then edit it in but I’m not sure why that should be necessary. I have played around with the options for accidentals but I don’t want to end up with a score cluttered with redundant ones.

Use the Properties panel for the E.

I knew about that but it’s an extra step when it seems just pushing the 0 key would do the trick.

I’m afraid there’s currently no way of forcing an accidental during note input. I think there is a good case to be made for having a key command that effectively toggles between the three states of the Accidental property for a selected note, and hopefully we’ll be able to do this in future.