Spikes when plugin is visible

Hey guys,

Recently I’m experiencing terrible spikes, in the performance meter I see the “Average load” and “real time peak” spiking and I can barely work on my projects.

It happens only in medium to large size projects, but it’s something totally new. And the strange thing is that it happens only when a plugin is visible, for example when I open a compressor, or any other plugin, it doesn’t matter which plugin, but the plugin has to be open. It can even by bypassed or turned off and there will be spikes so it doesn’t make any sense does it? But if it’s not visible and just working in the background there won’t be any spikes as well.

Does anyone know what can I do? I have no idea what causes it, or how to track it

Thanks a lot in advance

Has your computer recently updated the graphics driver? Has a windows update disabled a high power plan? Do you use the steinberg power plan?

There is a program called latencyMon which can help identify bottle nexts but you need to check all windows performance tweaks are in place.

These are assuming you are using a pc and not a Mac


Hello thank you very much for your answer
I just checked and what I did see is that the CPU performance was set to ‘optimize’ and not ‘maximize’, I’m not sure if it’s something that Windows had changed but I did have a Windows update recently.

Also my graphic card driver was updated I think, is there something I need to do about it?

Can you please tell me what you mean by Steinberg power plan? Are you referring to the option ‘Activate Steinberg Audio Power Scheme’ ?

Thanks a lot in advance this is really helpful


What graphic card do you use, please?

Hi Martin,
This is my graphic card and version:

Btw the Steinberg audio power scheme doesn’t help, still same problem

Yes it’s working!
It was indeed the GPU, I’m not sure what solved it because I did a few things in a row, but probably changing the NVIDIA settings to ‘performance’ over ‘quality’, thank god no more dropouts

Thanks guys!


I would recommend to do this:

  • Download the latest Studio driver version from here. If there is no Studio driver for your graphic card, use the one, which is available and continue with the same steps bellow.
  • Disconnect the computer from Internet to make sure Windows will not download and install own graphic driver.
  • Uninstall the NVIDIA driver.
  • Restart computer.
  • Start the NVIDIA driver installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.
  • Connect your computer to the internet.

Thank you very much for the instructions
For now it’s working properly after doing similar things but I did install the NVIDIA experience and all the other stuff unfortunately, but I’m afraid to touch it now as it’s working properly

If I ever experience those same problems again I’ll do exactly as you suggest thanks a lot

Hello Martin,

The problems are back. I thought it was gone but if the project gets a bit busy then the problem is back, it happens only with Waves plugins though.

I followed your exact steps, nothing helped.

Is there something else I can try? I really don’t know what to do?

And it was fine 2 weeks ago, so what could have happened?

If anyone else has experienced that problem and solved it please help

Thanks in advance

Guys I think I fixed it

Need to wait a few days to be sure but now with heavy projects I don’t have those issues.
Assuming it’s indeed fixed, after you follow Martin’s steps, you need to do two things:

  1. Open NVDIA control panel, select “use the advanced 3D image settings”
  2. Then in the “manage 3D settings” tab, select under power management mode - “prefer maximum performance”

And no more spikes!
Hope it helps someone in the future

1 Like


If it happens only with Waves plug-ins, I would definitely get in contact with Waves.

Could you try to reinstall NVIDIA driver the way I posted above, please?

I tried the way you posted, yes I will contact them thanks
If nothing works the only way is to reinstall Windows? It worked fine before the windows update