Split and draw tool interment when clicking with mouse

I’m getting an issue since upgrading to Cubase 9.5 where if I use the split tool to split a segment or part on the project page. Even though I can see it registering graphically so I know its not a mouse button issue, it only actually splits the track 50% of the time so I have to go back and keep pressing. Pretty annoying.
Is this I known bug?


No, I haven’t read about this. Could you try in Cubase Safe Start Mode, please?

Thanks for the reply

Tried in safe mode and the problem still persists. Now have a new mouse now too.
I exaggerated a little, it’s more like 30% of the time.
When it happens you can see it registering graphically that you’ve clicked the mouse button but it ignores the split.
Also noticed the same thing with the Draw tool.
Pretty irritating when I’m editing lots of audio and i realize it hasn’t cut the event and i have to go back and snip it again.
Also noticed sometimes randomly you cant grab the event fade handles until you update screen position/zoom.
Didn’t notice these issues in V9.
This is in Windows 10.

Fresh install of windows 10 with new built PC and i’m till having the issue. Tried 2 different working mice, Cubase safe mode without preferences, Don’t have this issue with the same mouse on my MacBook pro. It really feels like a bug not some kind of hardware issue. I’m working with UR28M and CC121 plugged in with latest Cubase 9.5 pro version. Create an empty project, create an empty audio or midi part and get the split tool and keep splitting it into sections for a test, and about 2 clicks out of 10 you can see it registering graphicly that you have clicked the split because the line flashes but it doesn’t split the part. I’ve even had it happen 3 times in a row.
It’s bizarre. Am I really the only one having this problem? :open_mouth: