Split beam in percussion staff

Hi Everyone,

I’ve just discovered that there is no way to properly edit rests in Percussion staves, which gives me quite a stomach ache, but I was wondering if at least there was some way of splitting beams that are mysteriously connected whenever I paste something into a percussion staff.

Screenshot 2021-08-26 at 12.18.29

For some reason these beams won’t split, no matter what I do, which really doesn’t make any sense to me.

Any hints?

It looks as though you have a very weird assortment of Notation Options set. Probably:
Beam Grouping > Simple Time Sigs Without a Half-bar … Join Beam at Tuplet
Quarter Note Denominator Time Sigs With Half-bars … Beam over rests
Beams and Rests … Use Stemlets

This first beat is easy enough to fix:
Select the three triplets. Edit > Beaming > Beam Together.
That should give you:

I can’t see a way of splitting the third and fourth beats without changing the Notation Options, though (and that’d be the option to beam over rests).

The underlying mechanics, as I understand it, are that in order for beaming commands to apply to rests, those rests have to be made explicit, which is the equivalent of forcing their duration. Percussion kits are effectively made up of a bunch of individual staves - one for each instrument - and then the notes are condensed down to a single staff (or a grid, as in your example). The rests are always implicit - they’re just visual padding - and as things stand it’s impossible for them to take on properties or react to beaming commands.

This has been addressed in Dorico for iPad, so the chances are the same fix will come to desktop Dorico whenever Dorico 4 is released.

Thank you! Maybe revisiting my Notation Options would be a good idea, too :wink:

Well yes. The chances are that if things are “mysteriously connected” when pasted into a percussion staff, you’ve manually overridden the Notation Options on the pitched source staff.

If you don’t like the rules, don’t break them - change them!

1 Like

Unfortunately, however, for instance changing the “Join Beam at Tuplet” setting leads to:

Screenshot 2021-08-26 at 13.03.44

…which, if I understand correctly, brings me back to problem #1.

Yes, I’ve seen your “rests in perc staves” workaround, but I don’t have that kind of time, unfortunately.

You might try playing with the meter popover. It’s a bit of a dark art working out which combinations override your Notation Options, but for your first example:

  1. Invoke the caret on the percussion grid.
  2. Shift-M [1+1+1+1+1+1+1+1]/8 Alt-Enter.
  3. Hide time signature from the properties panel (which’ll be possible as long as it doesn’t coincide with a global time signature change).

Should give you this, without manually beaming anything at all:

I don’t know what you want in your second example, but again it could probably be fudged with a hidden independent meter.

Oh nice! I’ll give it a try! :slight_smile:
Thank you!