Split point on grand staff after midi import

I’ve found that this topic has been discussed many time on this forum, yet, after much searching and reading I was still unable to reach a conclusion whether this can be done in Dorico or not. Here’s my situation:

I’ve imported a piano part into Dorico via standard MIDI file. Unfortunately, the entire part has been placed in the treble clef portion of the grand staff on import. In other words, I’ve got four octaves worth of leger lines hanging over an empty bass clef. I’d like to redistribute the notes. Is there a simple way to select only the notes below middle C in this staff and move those notes to the staff below via “opt M”?

I found a ‘filter notes by pitch’, which sounds kind of promising but I can’t make heads or tails of it. Is it possible to use this to accomplish my task? If so how. If not, can someone suggest an alternate way? Thanks in advance.

Bill, there’s two ways of doing it.

The first way is to switch to Galley View and literally draw a marquee selection box around the notes that protrude beyond the staff. Then Alt-N to send them up or Alt-M to send them down. You’d have to do this in a couple batches, but it’s actually pretty fast.

The other way is to select everything, right-click, Filter, notes by pitch, open the dialog box, and add pitches one at a time. But honestly, this is a little more tedious, because you have to select each pitch to add to the filter (can’t do a range). Then use Alt-M. FWIW, “filter pitch by range” has been submitted as a feature request and is in the queue).

I’d suggest the first way…

Did you try ticking “Use split point for grand staff instruments” when importing?

That’ll work. ‘Opt. M’ are ‘Opt. N’ are becoming invaluable in my new workflow. I didn’t know it was possible to marquee across a bar horizontally to include certain notes and exclude others. Thanks for the tip.

Yep, mark me down for this too. Even better, upon MIDI import, it seems to me if the software is smart enough to deduce ‘piano’ in the instrument name (which it did), and assign a grand staff (which it did), it seems reasonable to assume it might also be able to distribute the notes somewhat between the two staves in a semi-coherent fashion. I’m not sure why this fails to happen as often as it does, but I had the same problem consistently in Sibelius so it’s not unique to Dorico. Being able to fix this after the fact is important too. Thanks a million.

I don’t recall seeing this option. But yes, I’ll definitely check through all the available options on my next import. Perhaps this option should be checked as a default. It sounds like a feature I might want if I knew a specific split point I needed before importing, but not knowing a good split before-hand, my software should chose one by default. But then, I suppose once this ‘option’ is known to be ‘off’ by default, there is no reason to make the same mistake again, so thanks for alerting me.

Dorico does I think use a split point by default if you import a MIDI that it can recognise as being a piano. If you have a MIDI file that has tracknames such as ‘Intro part’, ‘Chords’, etc then there’s no way of it knowing that it’s actually a piano part. If the range of notes exceeds about 2 octaves then it will try to choose a grand staff instrument.

This track came into Dorico labeled as “Steinway Grand Piano”. It was accurately assigned to a piano sound and a grand staff, but all the music was placed into the treble clef and nothing in bass clef. No worries. I’ve since learned to check the box “set key spit point on grand staff instruments” and this does as advertised. This option is ‘unchecked’ by default. Maybe, now that I’ve used it once, Dorico will remember my preference on the next import and this option will be checked. I don’t know yet!

I don’t recall this being off by default. However it should remember the preference for next time.

What I’ve been trying to do as workaround is create a new flow and re-import the MIDI with a higher split point, and simply cut and paste that newly created part into the first flow, but all I get is a “Tacet” when trying to import. I don’t understand?

EDIT: found the issue. if “create all new players” is selected then dorico will only show “tacet” and no notes. if “merge with existing players” is chosen, the midi will be imported correctly. definitely a BUG.

I’m getting this Tacet issue right now whilst trying to import piano and separate a harp midi file. have spent 1 hour reexporting from pro tools. the midi file plays fine in windows media on its default midi piano. and yet dorico just gives me a tacet when i KNOW there is midi information and notes. this is so fustrating.

Have you checked setup mode to make sure the flows and players are all assigned to one another?

Check out page 11 of this document.

ah thanks dankreider. i seemed to have unintentionally fixed the issue though. i edited the post above.

Glad you got it fixed, but it’s not a bug. You just need to assign that player to the flow, or vice versa.

Because it’s a new player, it isn’t assigned anywhere until you do so. I encounter this all the time with XML import.

Ah okay. Honestly i dont really understand that entirely but ill keep choosing merge with existing for future midi imports. cheers

I’m a big fan of Dorico, but this is probably the weakest/poorest thing I’ve come across so far.

Yes, there is a split point on midi import. But for some reason the piano part in my midi is coming through as a Flute, so split point isn’t triggered anyway. *(But why have midi note no rather than pitch (eg C#2)??)

And yes, Opt-N is a neat and useful trick. but I now have to go through 40 bars of dense music doing this bar by bar. Drawing a box is fine in concept, but Dorico tries to ‘help’ by adding notes outside the box it thinks are part of the same chord. It’s almost always wrong, so I then have individually deselect these notes that were auto-selected…this all becomes a big pain real fast.

I’ll eventually get there - and thankfully it’s not 400 bars! - but still, all for the lack of a simple function to do this for you…

If your piano part is importing to Dorico as a Flute, it means the program that exported your MIDI did not identify the track(s) as Piano, so that would be where the difficulty originates.

If you can export as an XML file, that might make import into Dorico easier.

I’m sorry you’re finding this painful, but the good news (such as it is) is that MIDI import is getting a big overhaul and will be much improved in the next major version of Dorico.

2 Likes