Spontaneous rests

Hi Forum,

I am really liking Dorico 2, but I have found the apparently irrational appearance of rests in my score and would be glad to know if I’m doing something wrong or if it’s a bug, and, is there a workaround, please.
The notes I have entered have apparently spontaneously become second voices (stems down) and rests have appeared above them. This is not what I want and certainly not what I entered!

Some help would be greatly appreciated.


See attached file

The solution is to select them and ‘Remove Rests’.

But to prevent this from happening again, make sure you’re entering into the default voice, which is upstem 1. Despite the name “upstem”, the notes will appear with correct stem directions automatically.

My suspicion is that you started entering notes into downstem voice 1, leaving upstem voice 1 empty.

if you had started with the viola part, you could have used the ‘paste special to system below’ and just edited the last two bars of the cello part, then do the same a second time to paste it to the bass line.

Re pianoleo’s answer, I’m sure he’s right about what caused it. If you want to confirm that, under the View menu, in Notes and Colors (or something like that), turn on Voice Colors (or whatever it is), and you’ll see it for sure.

You can probably solve it with Remove Rests, per Steve’s suggestion, but I just found the same problem yesterday in a score I was engraving, and I chose to go through the whole score and select each Downstem Voice and Right-click/Change Voice to Upstem Voice 1.

If I had left the music in the wrong voice, it would have compounded the problem if I did any copy/pasting. That can quickly become a real mess otherwise.