SPP external hardware Sync while looping => ISSUE

Hi, I found an issue with my cubase 8.5 Pro and the Moog subsequent 37.
This is the first and only hardware synth in the chain.
The clock is set to midi clock and cubase is the master (no MTC).
Instrument setup as external instrument.

As long as i play a track, starting from wherever in the track, everything is in sync nicely and runs like it should.
The moog syncs perfectly and there is no audible delay or sync issue.

As soon as i set a ‘loop’ inside my track, The first time the parts are played there is still no problem. But as soon as the loop point is hit and the loop starts over, the moog loses it’s sync completely. It actually receives a SPP (Song position pointer) from cubase, probably a bad one…
As soon as i diasble ‘listen to spp’ in my external synth. The problem seems to be gone.

This means i cant use SPP but i do see the advantage of having it during producing.

Anyone with the same issue ?
Solved with an upgrade?
thanks in advance!

Thanks in advance!

Moog - MIDI over usb , soundcard focusrite 6i6, intel i7 8th gen, 32 GB ram, evo 970 SSD, cubase 8.5.??

Removed all external instruments and added them again.
I updated to cubase 10.

Now it seems to be solved.
case closed