SSD / soft-eLicenser

Greetings All,

I have searched extensively for answers to the questions below in both Dorico’s documentation and the forum, but am striking out on finding the information I need. I hope that you can help.

My machine is a 2019 iMac, and I’m running macOS Catalina - 10.15.7.

1 - I am trying to move my sound libraries to a dedicated SSD external drive, both the sound libraries that come with Dorico (Halion, etc.) and Kontakt VSTs. I’ve tried using the Steinberg Library Manager, but each time I try to move a library, it fails (all external drives are actually “greyed out” in the window, highlighting the fact that they seem unavailable for this action). I’ve tried deleting all the sound libraries (again, via the Steinberg Library) and reinstalling the sounds to the SSD via the Steinberg Download Assistant. When I did this, it downloaded the “HALion_Sonic_SE_and_Content_for_Dorico_Pro_3.4_Installer_mac” file downloaded fine, but when I began the installation process, it said “Sounds for Dorico Pro 3 can’t be installed on this disk. You can only install this software on the disk that is running macOS”.

This message runs counter to what I’m understanding Dorico’s documentation about what the Steinberg Library Manager makes possible - namely that you can move libraries to a separate drive to free up space on the main drive and facilitate smoother operation.

Is there a step I’m missing? Does the external drive need to be formatted in some special way? I’ve been using it for storing other projects without a problem, and there is plenty of space on it.

2 - In order to free up USB ports on my machine, I’d like to transfer my Dorco Pro 3.5 license from my USB dongle to the soft-eLicenser. Is this possible?

Thank you in advance for your help.


Joshua Stamper

Formatting is a good idea for portable drives…
License transfer is one way only (soft to usb)

Thanks for the reply.

The portable drive was formatted when I first got it - I’m curious wondering if it needs to be formatted differently in order to transfer Dorico sample libraries.

Thanks again…

Yes, it’s formatted, all right, but I just had a case on Windows… The drive was formatted with exFAT rather than NTFS, and the Vienna Library Manager protested violently when I attemped to store samples on it…

Ah - so it needs to be formatted as NTFS. I wonder if it’s the same for Macs. Researching on Google now.

Thanks for your help.

Definitely NOT NTFS for Macs. It should be formatted APFS.

I’ve transferred my libraries to an external SSD: you just click on the “Library Default Location”, from the cogwheel at the top. You can also use the “Move” button.

Thank you. Right now it’s currently formatted as Mac OS Extended (Journaled).

If I reformat to APFS, will I be able to put everything that’s currently stored on the drive back? (obviously I’ll need to move things off the drive to reformat since reformatting wipes the drive). Or do I just need to find a home for non sound-library content?

Well, HFS+ should work too: it’s just another Mac format. (APFS is newer and has advantages on SSDs.)

You should be able to convert the drive non-destructively using Disk Utility’s “Convert to APFS” command. See this article for proof!

But of course, any files that you don’t want to lose should be backed up.

Thanks so much!

Greetings All,

Just a quick note to let you know that the fix was actually extremely simple (much and many thanks to Steinberg Tech Support): the SSD drive didn’t need reformatting after all. It was simply a matter of putting creating a dedicated folder within the SSD drive for the libraries (as opposed to moving the libraries directly to the drive).

Very simple / total fix.

Thanks again to everyone for jumping in to help!!

Joshua Stamper

Very glad to hear it was solved simply and quickly.

It was terrific.

Also, how do I mark this post as [SOLVED]?

It looks like you already have! There’s a little checkbox option in the “more options” menu at the bottom of each post, which you can open by clicking the three little dots immediately to the left of the “Reply” button.

Ah - thanks!

I had clicked that box, but didn’t realize that was all there was to it.