SSD5 Free blacklisted

I’ve spoken with Slate Digital and Steinberg and this is a mysterious issue as nobody can figure out the problem. Recently I upgraded my system from 3930K to 2700x. I said what the hell, let’s give amd a whirl and so far, so good. The one weird issue is SSD5 Free. It worked perfectly fine on the 3930k system but on this system, it gets blacklisted. The only difference, apart from the obvious Intel/AMD, this new computer has Win 10 Home while the Intel has Pro. In the plugin manager, when I try to reactivate, it fails and states to contact the vendor. I’ve tried it all: uninstall, reinstall, Install on a different drive (in case of permissions), reset plugin list, deleted blacklist.xml file. If anybody has other ideas, please chime in.

Win 10 Home
Cubase 9.5.41

Tested 9.5.5 recently as well, same result.

This has quite a few people stumped.


Amazing, nobody can figure this out.

Over a year later, and I have finally figured this weird problem out. For anybody else who experienced this “problem,” which wasn’t many, need to install SSD5 into a “public” folder on the computer. Usually C:\Users…etc

For some reason, maybe it’s the way the drives were oriented and how they communicate permissions or allow them, a public folder is the full-proof way to always allow permissions for SSD5 and whatever other related resources to be called upon so to speak and work normally rather than be Blacklisted. Problem solved.