Stability problem with 6.5.3? (Crash)

I did a update yesterday, and I leaved the application running in playing in loop mode over the night.
Process: Cubase 6 [8394]
Path: /Applications/Cubase 6.app/Contents/MacOS/Cubase 6
Identifier: com.steinberg.cubase
Version: 6.5.3.153 (6.5.3.153)
Code Type: X86 (Native)
Parent Process: launchd [146]

Date/Time: 2012-08-09 02:09:55.658 +0200
OS Version: Mac OS X 10.7.4 (11E53)
Report Version: 9

Anonymous UUID: 0B872625-6044-4C1C-8520-C6901E2A2484

Crashed Thread: 55 VST Realtime Slave 5

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000001

VM Regions Near 0x1:
–> __PAGEZERO 0000000000000000-0000000000001000 [ 4K] —/--- SM=NUL /Applications/Cubase 6.app/Contents/MacOS/Cubase 6
__TEXT 0000000000001000-0000000001ddf000 [ 29.9M] r-x/rwx SM=COW /Applications/Cubase 6.app/Contents/MacOS/Cubase 6

Application Specific Information:
objc[8394]: garbage collection is OFF

Thread 0:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x94ea0c22 mach_msg_trap + 10
1 libsystem_kernel.dylib 0x94ea01f6 mach_msg + 70
2 com.apple.CoreGraphics 0x992a45f9 _CGSSynchronizeWindowBackingStore + 167
3 com.apple.CoreGraphics 0x99266cdd _CGSLockWindow + 4709
4 com.apple.CoreGraphics 0x99265773 CGSDeviceLock + 317
5 libRIP.A.dylib 0x9152b381 ripd_Lock + 62
6 libRIP.A.dylib 0x9152aef0 ripl_BltShape + 620
7 libRIP.A.dylib 0x915285c7 ripc_Render + 386
8 libRIP.A.dylib 0x91524d0b ripc_DrawRects + 618
9 com.apple.CoreGraphics 0x99263cab CGContextFillRects + 150
10 com.apple.CoreGraphics 0x99308564 CGContextFillRect + 32
11 com.apple.AppKit 0x905ce62c NSRectFill + 197
12 com.apple.AppKit 0x90a390c7 -[NSNextStepFrame drawRect:] + 113
13 com.apple.AppKit 0x90555989 -[NSView _drawRect:clip:] + 3929
14 com.apple.AppKit 0x905539a8 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:]

  • 2650
    15 com.apple.AppKit 0x906a5c70 -[NSNextStepFrame _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:t
    opView:] + 286
    16 com.apple.AppKit 0x9054de9e -[NSView _displayRectIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:] + 4817
    17 com.apple.AppKit 0x90546dc9 -[NSView displayIfNeeded] + 1365
    18 com.apple.AppKit 0x906a5b3f -[NSNextStepFrame displayIfNeeded] + 91
    19 com.apple.AppKit 0x90543b8d -[NSWindow displayIfNeeded] + 316
    20 com.apple.AppKit 0x90546698 _handleWindowNeedsDisplayOrLayoutOrUpdateConstraints + 804
    21 com.apple.Foundation 0x98428bab __NSFireTimer + 166
    22 com.apple.CoreFoundation 0x95eea2a6 CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION + 22
    23 com.apple.CoreFoundation 0x95ee9c37 __CFRunLoopDoTimer + 743
    24 com.apple.CoreFoundation 0x95ec8cd0 __CFRunLoopRun + 1888
    25 com.apple.CoreFoundation 0x95ec81dc CFRunLoopRunSpecific + 332
    26 com.apple.CoreFoundation 0x95ec8088 CFRunLoopRunInMode + 120
    27 com.apple.HIToolbox 0x98d8f723 RunCurrentEventLoopInMode + 318
    28 com.apple.HIToolbox 0x98d96a8b ReceiveNextEventCommon + 381
    29 com.apple.HIToolbox 0x98d968fa BlockUntilNextEventMatchingListInMode + 88
    30 com.apple.AppKit 0x905060d8 _DPSNextEvent + 678
    31 com.apple.AppKit 0x90505942 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 113
    32 com.apple.AppKit 0x90501cb1 -[NSApplication run] + 911
    33 com.steinberg.cubase 0x015f63ba CSOLOISTExtendedAnalysis::~CSOLOISTExtendedAnalysis() + 3263258
    34 com.steinberg.cubase 0x015f75b4 CSOLOISTExtendedAnalysis::~CSOLOISTExtendedAnalysis() + 3267860
    35 com.steinberg.cubase 0x013d2330 CSOLOISTExtendedAnalysis::~CSOLOISTExtendedAnalysis() + 1018512
    36 com.steinberg.cubase 0x0138995c CSOLOISTExtendedAnalysis::~CSOLOISTExtendedAnalysis() + 721084
    37 com.steinberg.cubase 0x00dc0f1b 0x1000 + 14417691
    38 com.steinberg.cubase 0x012468fc 0x1000 + 19159292
    39 com.steinberg.cubase 0x000e3766 0x1000 + 927590

It only last little more than 4 hours on small project. Cubase memory usage was about 1.5 GB. So it was not out of memory.

Aloha c,

While looping, did your 'puter go into ‘Sleep/Screensaver’ mode during the night?

If so,
Try going into the ‘Energy Panel’ and make sure nothing is allowed
to go into ‘Sleep’ mode. (Computer,Hard drive etc)

Even your monitor should stay ‘on’ just like it 'would
if you were actually working at the computer.

Pressing keys/moving the mouse periodically should also be considered.

Disable all internet connections.

(In certain situations Bluetooth might also be problematic).

Then try the test.

Cron scripts running overnight might also cause probs.


{’-’}