Staccato after glissando not being played back

I have a project where I have a delayed glissando up to a note that is staccato, however, the staccato note is not being played short.

My settings for staccato notes are set to be 25% of the note duration, and I’ve unticked the box for setting a maximum duration of notes for staccato to be considered.

If I remove the gliss, the note is played short as expected. Is there anything that needs to be set to make this work?

Screens of the settings and relevant parts:-

Screenshot 2023-01-05 at 09.50.40
Screenshot 2023-01-05 at 09.50.52

And the project file:-

God Only Knows - (1.4 MB)

I’m not sure of the exact reason, because I’ve not stepped through the playback code to see what Dorico is actually doing, but it clearly doesn’t apply the MIDI effect for an articulation to the last note in a glissando.

You can manually edit this yourself by setting the Key Editor to show sounding durations rather than written durations, then shorten the duration of the note at the end of the glissando.

I agree that in principle Dorico should still be able to manage this on its own, and we’ll look into this in due course for a future version.


OK, it’s no biggie as I dump the midi down into Ableton Live when doing a mixdown in any case for further editing and so on.

What’s curious is that any expression map articulations are being applied, but the note length isn’t being shortened. The Bass Trombone here is still using the NI Session Horns Pro plugin which just uses keyswitch articulations, whereas the rest are on VHorns Saxophons/Brass respectively, where the VI plays the articulation based on the note length only.

Thanks for the prompt response as always!