Stacked Midi Lanes Not Muting


I’m using Cubase 10. Trying to record midi. I have the options set to “New Parts” and “Stacked”. My understanding is that if I record over a part multiple times it should create new lanes and all but the current lane is muted automatically.

The new lanes are being created - but all the lanes are playing back at once.

What am I missing?


Do you record in Cycle? The Stacked settings is for the Cycle recording only. If you stop and hit record again, this is other case.

I think I’m seeing the same behavior. With “New Parts”, it properly adds new parts, but I’m hearing my prior take. With “Merge”, it merges (as it should), and “Replace”, it replaces the existing take (not a new lane). Clearly different behavior than for audio (frustratingly, I wish I had the option to hear my prior takes - see my other thread)

The only thing I’ve found that works is to use the “versions” feature, mute any existing clips, or “solo” the new lane (the problem with this is that as soon as you collapse the lanes view, it “un-solos” and you hear the mashup of all the takes. A little frustrating.

It should at least be consistent with audio handling.

Maybe someone has some other ideas? I also looked through the manual and couldn’t find a lot of detail explaining the workflow around this and where it might say “you need to mute the prior clips if you want to create new parts”. I’m not sure I’m doing it right…