Staff spacing in parts

Hi,
I am having problems to manage staff spacing in parts. I would like to compress spacing of several staves holding alt and clicking the large square, but I only can move one staff at the time… I have also tried to select multiple large squares but it does not work.
Any ideas, please?
Thanks!

Delete. Misunderstood question.

I can certainly compress spacing of several space by holding alt and dragging a single large square handle with the mouse. As far as I can tell, it’s not possible to do this from the keyboard. Pardon the stupid question, but are you sure you’re in staff spacing mode, and not note spacing mode?

As parts are only (usually) one staff per system, the easiest ways to change the spacing of several staves at once are:

  1. Reduce the Vertical Spacing between systems in Layout Options for the part.
  2. Use Frame Breaks with “Wait for next Frame” to force the desired number of systems per page.

Thank you for your answers.
Dear andgle, yes, I am in staff spacing mode, as I can move the staff, but only one is moved when pressing Alt and dragging the big square.
Dear benwiggy, a general setting change is not useful here, as I need to change staff position after changing the default position of some items (for example staff text). Default staff spacing does not consider this manual position changes and leave a too large gap that have to be manually adjusted. I would like to move all staves at the same time, but I can only move one.
I enclose example. The “Escena 1” label has been manually moved down and it has left a larger staff separation that is not corrected automatically (it would be really nice that Dorico corrected this separation, but as far as I know it doesn’t). I would like to drag this staff a little bit up and that the rest of staves accommodated automatically, but I can only move them individually:

This isn’t answering your question directly, but for staff spacing, the keyboard is MUCH faster! I can modify a dozen systems on a page in 15 seconds. (That might be a bit of a fish story, but it sounds great.)

Thanks dankreider, it is a good point. You are right, but if this could be solved with a simple mouse drag it would be great!

The main problem, I think, is that alt-dragging only compresses spacing between staves, but you can not expand the spacing. Maybe shift+alt+drag could do that. Just an idea.

Correction: alt-dragging does not work for compressing staff distances under specific conditions which I have not been able to reproduce… After removing staff distances changes I can compress staff distances again… Very strange…

Is it just me, or has this behaviour improved in recent versions? I find that the tempo marking automatically appears to the right of the rehearsal mark in all layouts, even when the tempo marking is attached a bar later than the rehearsal mark. Sure, you then need to move the tempo mark to the correct place, but you don’t then have to fight Dorico’s staff spacing adjustments.

I think there’s a setting to change this behaviour, but for me it is not useful in any circumstance, so in general I prefer so keep tempo under rehearsal mark. I have shown this change just as an example of how a gap can appear due to manual change of item positions.

Well in that case you might consider using System Text, turning on the border and turning off “Avoids Collisions” (rather than misusing Rehearsal Marks). That way you don’t have to fight Dorico in regard to staff spacing.

I followed your excellent advice here:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=156669
:slight_smile:

My excellent workaround has certain advantages, but as you’ve spotted it also has disadvantages…