Staff Spacing with text

I’m sure this is addressed somewhere already, but I’ve failed to find it.
It appears that all of my text instructions are causing Dorico to space things out quite widely. In Layout Options, I’m only seeing ideal gaps for things between staves, but nothing for ideal gaps with text, which seems like the issue here? Dorico is adding too much padding between the text and that stave above it, and I’d like this to be tighter. It really seems like I’d only need a little bit of extra space to accommodate the text here.

P.S. It just occurred to me that it could be caused by the boxes as well. They’re custom lines, with one for the top and another for the bottom half of the box (which allows me to stretch them vertically). So maybe it’s a setting for spacing for the box “lines” rather than the text. Though I just tried deleting half of the boxes and the spacing didn’t change, while deleting half of the text did shift the positions of the staves I deleted it from.

This is likely due in part to your settings for Vertical Justification (in Layout Options, Vertical Spacing). If the “fullness” exceeds the set threshold, Dorico will vertically justify the entire thing, expanding it significantly.

Try increasing your percentage there for starters, so that Dorico isn’t too quick to fill the frame.

1 Like

Yeah, I thought of that, which is why I set both to 100% (I didn’t find an option to completely disable the function? And attempting to set it to greater than 100% doesn’t appear to be allowed). But they still engage because for some reason Dorico thinks the page is at 106% full, which it clearly is not.

Not sure why it thinks it’s so crowded with all the white space present.

There are different settings that can have some weight there. First thing I’m thinking of (since it should not be that tight once the problem is solved) is selecting the text above the boxes, in Engrave mode enabling the “Avoid collisions” property and making sure it’s left unticked. Which basically means : won’t avoid collisions, or won’t space staves out. You can then manually nudge them up if needed, without any interference on the spacing of other items on the page.
If this does not solve the problem, I’d change the interstaff settings in Layout Options>Vertical Spacing>Ideal gaps. I’m talking about the two settings that are below the first set of options, where default values are 1 and 2. I’d set those to 1/2 and 1.
I’m quite confident the problem should be solved by now.

Set the Minimum gaps in Layout Options > Vertical Spacing to a smaller value.

You could also try selecting the text and turning off collision avoidance in Properties. (Engrave mode.)


Also, you want two Ps and a fullstop in “approx.”, and an R in asynchronous! :stuck_out_tongue:

Thanks for the pictures. That’s basically all I wrote three hours ago :rofl:

“TL;DR”. :rofl:

Note that your “avoid collisions” pictures would not really help. The property must be engaged (left button on) and the property must be unticked. Which I think I explained in my Too Long answer :wink:

1 Like

Thank you all! The avoid collisions being disengaged definitely proves that this is what’s separating everything so far apart. In regards to altering the ideal gaps, I don’t want to mess with that because the rest of the score looks very nice with the current gap settings I’ve made/defaults (I’ve tweaked so many things, I have no idea if they’re the defaults or not now). Regardless, everything outside this spot is spaced beautifully, so I don’t want to mess with those.

While I can certainly use manual adjustments (with collisions turned on and push them closer, or collisions turned off and spread them out), the philosophy of Dorico really seems like there should be a way to inform Dorico how much padding I want applied to the text.

For example, this other passage also uses text but the spacing looks great!

It’s all staff text, attached to the music. But for some reason (maybe some interaction between the text and boxes combines??) the spacing is totally out of whack in the first example and totally fine in this one.

By any chance, were the boxes around short musical phrases on your 106% full page created using text items? Which you manually moved in Engrave mode onto the staff, but didn’t disable text collision avoidance for before doing so?

Because if that is the case, that would explain why this page appears to be 106% full: Dorico is continuing to factor in both the “Repeat asynchronous, approx speed” text items (there are two typos in each of your text items, by the way), and the enclosure rectangle text items in the vertical spacing calculation.

In Dorico, vertical spacing is a burger: fillings stack up on top of each other. You can see whitespace because you’ve moved things around; Dorico still knows where those things are “supposed” to go, and accounts for them. Disabling collision avoidance for text items essentially says “Dorico, please ignore this”.

For general vertical spacing advice: set the “Ideal Gaps” to the lowest value you would accept. Let Dorico add extra space, if available, on top of these gaps when staves/systems are vertically justified. The smaller you set these gaps, the fewer overfull pages you’ll end up with, and the more flexibility Dorico will have to grant more space to busier staves (because the less-busy staves are demanding less minimum space).


Ack, Benwiggy pointed out those typos and I totally forgot about them by the time I’d finished getting caught up reading the thread! Thanks for pointing them out again. So embarrassing!

The boxes are actually pairs of custom lines. One line on top and one line on bottom with ending brackets pointing up and down respectively. This lets me attach it to the music, size them horizontally in musical divisions (that will stretch with the music) and adjust them vertically by just altering how much the brackets overlap.

But indeed, there’s some sort of collision avoidance going on with them, because the top line, for whatever reason that I’ve never been able to figure out, insists on starting far above the staff and not letting the the brackets cross the staff lines, while the bottom one (which has the same settings but flipped) doesn’t have this issue. So I am still manually pulling those down from their default position to form the box, which probably is resulting in the same vertical spacing effect that you’re describing if they’d been text boxes.

Following this reasoning, I tried deleting the top stave’s top half of the box and realized that my tempo marking is also pushed way way up because it’s also trying to avoid the bracket’s default placement which is really high up.

This leads me to think that the issue is actually being caused by the starting positions of my top part of the boxes, even though that doesn’t seem to comport with how everything collapses in if I delete the text??

The tempo mark actually resets to its correct position if I delete the text OR the top bracket from the first stave.

Sorry, I guess I’m really getting into the weeds here with complications caused by me messing with custom lines and using the application in ways it wasn’t necessarily designed for.

I would think that the collision avoidance would space things based upon the position of the object, rather than the default position regardless of its manual adjustment. So you’re saying that moving things manually does NOT update the collision avoidance rules at all? Moving something down doesn’t inform things above it that they have extra space below them they can move in to?

If these are horizontal lines, and you intend them to be positioned ultimately inside the staff, have you tried first positioning them inside the staff semantically, before dragging them around? (Or better yet, changing their staff position)

Probably to avoid colliding with the text item – does it still start from a far-away position if the text item has collision avoidance turned off?

This is related to my comment about burgers: items get positioned relative to other items. If there’s already gherkins, the lettuce ends up further from the patty. Or something along those lines.

Your line items by now have significant offsets set for their properties in Engrave mode. When you delete text items or disable collision avoidance for them, the lines will be positioned relative to the staff, ignoring the text that used to be there, but retaining the offsets you manually set: Dorico preserves your overrides, although the base position is now different.

This is why it’s best to leave manual moves of things until you’ve adjusted settings etc to be as close as you want to your end result. You’ll end up with less work to do to start with, and less work to do later if changes are needed.

1 Like

I guess “above” vs “inside” is a bit subjective in this case, as I’m looking for the main horizontal portion of these lines to be outside the staff (above or below respectively) but to have the end caps be “inside” the staff. Perhaps the better method then would be to define both the lower and upper portions of the box as “inside” the staff and then define them separately by some defined offset upward or downward?

And you’re right, the top line gets shoved way high up when the text is present, and I have to manually pull them back down. But without the text, the box lines look perfect at their default positions.

Interestingly, if I start over and get the box lines in place, just writing “repeat” doesn’t cause the avoidance to move anything, it’s only once the text is long enough that it includes “asynchronous” that things start shifting around. I don’t see why that would matter, as the staff I tested this on didn’t have any higher notes later in the bar or anything, so I’d think the vertical considerations would be unchanged between having one word vs multiple.

Screenshot 2023-11-11 at 2.39.15 PM
Screenshot 2023-11-11 at 2.39.32 PM

For more detailed advice, you’re going to need to share the project (or a version of it). Otherwise this could be a very long, very tedious game of “guess who”.

Edit, after taking in the pictures better: that text item where you’re adding “asynchronous” – does it have collision avoidance enabled or disabled? If it’s enabled, that would explain it: when it’s longer, it spans the end point of the line, which then Dorico helpfully moves out of the way for you.

Yes, from your perspective you’re seeing these as being “above” the staff, but from Dorico’s perspective, these are lines with pretty tall caps: that’s a lot of space to accommodate. The mid-point vertically of each of these lines ends up sitting pretty much bang in the middle of the staff, so tell Dorico that’s where you want them, and things will probably run more smoothly.

And now I realize (though it doesn’t solve what I should do to resolve the issue) that if I just move the text over to the continuation lines, everything spaces just fine! But ideally, I’d know what settings are causing things to jump around so if I ever have text that isn’t just about how to continue and does actually need to be over the box itself, I’d know how to do it right.

You could probably also reduce the minimum gap between text items and the staff, in Engraving Options > Text.

This is making more sense. The continuation lines are set for “inside” the staff, so they’re not being accounted as “above” the staff - which would explain why nothing is funky if the text is over them instead.

It seems that the better method with this is to define the box lines as “inside” and then define some kind of offset to have them appear below or above the staff respectively?

Yes I believe that’s what I recommended earlier :slight_smile: give Dorico the closest semantic position instructions you can, and work from there.

I.e. use the in-built options to get your line 80% to where it should be, then move the remaining 20%, rather than drag manually 100%.

You can, as mentioned a few times now in this thread, disable collision avoidance for text items specifically so they’re ignored in vertical spacing calculations.