{@stafflabelsshort@} Roman numbering


Is it possible to show roman numerals with {@stfflabelsshort@} token?

I would like the default page of a part layout to show for example ”title - fl. II” at the top of the page. Now it’s showing ”title - fl. 2” although everything else uses roman numerals.

I also had some other issues today:

Is it possible to edit instrument transpositions (Corno in Fa or Clarinette in Sib)?

And is there a general switch to add a dot after the shortened names: ”Fl. II” Instead of ”Fl II”?

Thanks for the 3.5.10 and good summer!


Are your staff labels already set to show as Roman numerals?

Instrument transpositions: there should be alternative transpositions available in the instrument picker, either when you add a new instrument or change an existing instrument. If you change an existing instrument, all music already on their staff gets transposed etc if necessary. Ah, do you mean to change what language instruments appear in? If so, that’s an option in Engraving Options > Language for all subsequent instruments you input (it doesn’t affect existing ones, although it might if you change them?)


Yes, I had already the stafflabels set to roman numerals. This was the only thing that didn’t change for some reason. But maybe the Page of that part had been edited? I’ll check it tomorrow!

At the moment, the {@staffLabelsFull@} and {@staffLabelsShort@} tokens don’t take into account the engraving options for whether to show the instrument number in Roman numerals, but I’ve made a note of this for the future.

Great, thank you!