Stagger on two alternating tracks - Bug?

I’ve never used this function before but thought I should give it a shot after watching Justin’s great video recently. However, for some reason I don’t get the tracks on two alternating tracks, but instead I get a separate track for each file. Am I missing something or is this a bug?

There are 3 options.

All on one track, staggered on two tracks, or all on their own track and all clips placed at 0:00 (or wherever the cursor is). Are you sure you chose the 2nd option?

I’ve done this about a million times in the last 10 years and have never had it not do what was intended.

Absolutely sure, exactly the same options and I tried it several times. They come out staggered but on different tracks. They’re sort of paired, so one will go on the track below the one before, but all on separate tracks. I’ll try it out tomorrow and make a screenshot.

When you say ‘sort of paired’ … these are stereo tracks correct? Not dual mono?


with Staggering Files box used
Try tick box or combo(s) with
“Start Inserting below Selected Track”
“Use Existing Tracks (Create New Tracks If Necessary)”

it works here on WL 10.0.40 and OSX 10.14.6 Mojave

regards S-EH

Ok, back with some screenshots. Here are the settings (although I’ve tried a bunch of things):

Here’s the result:

Also tried with other files. Same thing, but not one track per file but a mixed salad:

One more:

Be sure to place the Mouse-Pointer in the upper trace, before you import the clips into the audiomontage (you should see the vertical yellow line in the upper trace only).
Otherwise additional traces are added.
Hope that helps

Just tried that, same result.

Wow, that is very strange. How many tracks are in the montage before you try doing this? All I can think is that this is a strange bug, in which case PG would need to know more details about your operating system, source files, and other details to reproduce…or maybe if you have more than a few tracks already existing in the montage, it spreads them out like this instead, but I’ve never tried doing this with more than one existing track.

Either way, I have never seen it produce that kind of result so it must be either a bug, or a strange loop-hole somewhere.

I’ve tried all kinds of different things, starting with one track, two tracks, etc, always the same result.

I’ll be happy to provide whatever info is needed to track down the bug! PG, let me know what you need.

I think what would be best, is a screen recording video to get the full picture of what’s going on. Also, always important is your operating system version and confirming which version of WaveLab you are using. 10.0.40 for example. I have never in 10 years seen WaveLab do what you’ve shown in the photo so there has to be an explanation. Could be the source files, a quirk with your OS/WL version combo, or something else hard to notice in screen shots and text only.

Win 10 v1903
Wavelab 10.0.40

Looking into screen capture now, will post as soon as I’ve sorted it out.

Alright, here it is:!Ar3W-MwG-a_i6XdTgLfAwkdhj-rX?e=evmkB1

As you can see, I tried with three different sets of files. In the second one I tried, it actually worked as expected. I’ve tried with other file sets now as well, it’s like 50/50 or something. Seemed to be linked with file naming (like “number” - “name”) but then that didn’t work with another file set so that wasn’t it.

Interesting. I don’t think I have software that can play an mkv file but maybe PG will see this and can figure out what’s going wrong because the 2nd option for staggering should only create a total of 2 montage tracks, and stagger the clips from track 1 and track 2 back and forth.

Changed it to an mp4, maybe that works better?!Ar3W-MwG-a_i6XjTRxOgEIw3l10G?e=3Xq8wB

Yeah, this video actually plays right in the web browser too, and would probably play in Quicktime etc.

Anyway, now that I see your workflow, I thought at first it was going to be because you are dragging files in right from the File Browser which I have never used before. I simply use the shortcut to Insert Audio Files and a window pops up to select the files. However, I just tried your method and I still get just two tracks.

I’m on a Mac though. I think PG will have to weigh in on this bug or loophole but if you do the Windows equivalent of SHIFT + Command + I to insert the files instead, do you get any difference.

To me this feels like a Windows specific bug or loophole that somehow you’re only experiencing or reporting.

This looks like a bug. But I can’t reproduce it.
I can’t detect on your video, the difference when it does not work, and when it works, at the second attempt. What do you do differently?

The only difference is the files I use. I could also add that the result for a particular file set always seems to be exactly the same, i.e. the files always end up in the same configuration on the tracks.

Justin, I have tried both with dragging them down and inserting them with the file selector, the result is exactly the same.

Wow. For the first time in 10 years, I had this bug happen to me today, and it was a 6 song project like the one in your picture.

I think I might know the problem. Did this project contain a file with a really short file name?

Today I had a file that was mistakenly just named:

And when I did my usual thing, the files ended up on more than two tracks like your picture. When I went back and correctly named the file from r.wav to a longer and correct name, the problem went away.