Stagger on two alternating tracks - Bug?

Alright, back with some test results:

I started out with a set of files that gave me 3 tracks when importing. Changed the names to all files to “a.wav”, “b.wav” and so on. Got something like 6 tracks. Changed the names to 1a, 2b, 3c and so on, then it came out correctly on two tracks staggered. Changed the names to aa, bb, cc etc, same result with that.

Went back to the original files with the original names, imported all but one file to see which one was causing problems. In this case it was specifically one file called “Wolves of Ardeal.wav”. Excluding that file will stagger on two tracks. Renaming that file to something else, INCLUDING renaming it to “a.wav” will make the files stagger correctly. Changing the name back to “Wolves of Ardeal.wav”, back to the same behavior. Changing it to “Wolves of.wav”, works correctly. Changing it to “Wolves.wav”, works correctly. Changing it to “Ardeal.wav”, now I get 4 tracks.

Further experimentation:
“ar.wav” = 4 tracks
“rd.wav” = 2 tracks
“de.wav” = 2 tracks
“ea.wav” = 2 tracks
“al.wav” = 4 tracks
“at.wav” = 2 tracks
“el.wav” = 5 tracks
“et.wav” = 2 tracks
“e.wav” = 2 tracks
“r.wav” = 4 tracks (shoutout to Justin)
“er.wav” = 5 tracks
“erer.wav” = 5 tracks

Now, as fun as it is to spend the weekend experimenting with this, I think I’ll tend to something else for a bit. :wink: But I think we’ve narrowed it down to that the name is key. Also doesn’t seem to be the length of the name, but rather a combination of letters in the name, or specific letters.

PG, did you check if you could replicate this issue with the names on your end?

I did not check yet. It’s on my todo list, but I have other priorities at the moment.

FWIW, I have noticed that if I copy and paste a name from a file (for example a simple word docx) that was generated in OSX I can get weird behavior. I first noticed it when doing a simple copy and paste from a word doc and found characters gone astray in CD text and some other places.

But if I retype the same text in WL, it ‘works’ as expected.

Of course, I’m not sure that this is relevant to what you are experiencing but I thought it worth mentioning.

l. and r. consistently fail in your list (left and right?), but it doesn’t necessarily carry over into longer words ending in l and r.

It does (check the examples in the paragraph before what you quoted) but I didn’t figure out the pattern for it. But since you now mentioned it, I looked at the files that I was experimenting with. The only one that ends with l or r is “Wolves of Ardeal.wav”, the very one I had problems with. So, a bit more experimentation:

  • Still excluding “Wolves of Ardeal” for now.
  • I have one file called “Bleak Prismatic World.wav”. Changed it to “Bleak Prismatic Worldl.wav” et voila! Now I get four tracks. Changed it to “Bleak Prismatic Worldr.wav”. Same thing, four tracks. Change it back to the original name=back to the correct 2 tracks.
  • Including “Wolves of Ardeal.wav” again but changed the name to “Wolves of Ardea.wav”. There it is, 2 tracks. Changed it to “Wolves of Arear.wav” and I get 3 tracks.

So “l” or “r” at the end makes the difference.

About the naming and copying text in, I actually encountered something like that the other day where a band had an “Ê” in their band name, which I copied into the meta-data and got something else in the actual mp3 files. I didn’t try to actually type it in rather than copy, I should try that.

Right, in those cases and some other cases, but I’m pretty sure I tried it with some other longer titles ending in l or r (sorry can’t remember them offhand), and they came out ok, so I thought it was more complicated than just any title ending in l or r. Besides, it probably would have happened much more often if it was just a case of all titles ending in l or r.

Putting it to the test now. Using different sets of files, randomly changing names and adding in r or l as the last letter. In every case so far, the result is multiple extra tracks.

EDIT: Also, in file sets that have one or more files ending with l and/or r, I get extra tracks, and renaming the files removing the l and/or r consistently makes it work as it should.

What if you find another project that has a filename that already ends in l or r, so you’re not changing names to add or remove l and r?

That’s what I did. They come up on multiple tracks.

I guess you’re right. I can’t reproduce what I was talking about, so I guess the problem is any filenames that end in l or r, unless somebody finds otherwise.

So crazy that in my 10 years of using WaveLab, this only happened once and it was not long after the original post. Either it’s a new bug, or necromorbus found a needle in a haystack.

My takeaway here is that if it ever happens again, play with the file naming, or deal with reorganizing the files on two tracks as intended.

Hopefully when PG has time he can look into the true cause of it.

Hi Everyone,

I had the same issue. I had 18 wave files I was trying to import, but Wavelab [10.0.40 - build 127] just keeps scattering the files on multiple tracks (10 in all). No matter what I tried, I couldn’t get it to stagger the files on two tracks as advertised.

Here’s the link to the video: https://streamable.com/8p2z7e

After playing around with the filenames I got it to work. I also found out what the problem was: I’ve tried multiple file naming conventions and it seems that Wavelab doesn’t like a dash in combination with L, R, C and S at the end of the filename (no space). So anything like Master-C.wav or Master-L.wav will not work. Master_C.wav (with underscore) will work and Master - C (dash with space) will also work. Also, L and R work neither with dash nor underscore.

The rule for C, which doesn’t work with - (dash) but works with _ (underscore)

-C at the end of filename, does not work (dash, no space)
_C at the end of filename, works (underscore, no space)
_ C at the end of filename, works (underscore with space)

  • C at the end of filename, works (dash with space)
    C at the end of filename, works (space, no dash, no underscore)

The rule for S, which doesn’t work with - (dash) but works with _ (underscore)

-S at the end of filename, does not work (dash, no space)
_S at the end of filename, works (underscore, no space)
_ S at the end of filename, works (underscore with space)

  • S at the end of filename, works (dash with space)
    S at the end of filename, works (space, no dash, no underscore)

Special exception for L, which works neither with - (dash) nor _ (underscore)

-L at the end of filename, does not work (dash, no space)
_L at the end of filename, doesn’t work either (underscore, no space)
_ L at the end of filename, works (underscore with space)

  • L at the end of filename, works (dash with space)
    L at the end of filename, works (space, no dash, no underscore)

Special exception for R, which works neither with - or _

-R at the end of filename, does not work (dash, no space)
_R at the end of filename, doesn’t work either (underscore, no space)
_ R at the end of filename, works (underscore with space)

  • R at the end of filename, works (dash with space)
    R at the end of filename, works (space, no dash, no underscore)

I actually went through the whole alphabet to see which letters work and which once will not work.

To avoid the bug: When using a dash with a letter at the end of your filename, either add a space between the dash and the letter or use “underscore” instead of a dash. Using a dash with either the letter C, L, R or S (caps or small) without a space (between dash and letter) at the end of a filename will cause the “stagger on two tracks” feature in WaveLab to fail. Also, L and R don’t work with dash or underscore. All of the four letters will work when a space is added.

The easiest way to avoid problems, is to use dash or underscore in combination with numbers instead of letters (to designate filename version at the end of filenames). So ending your filename with “master-1” or “master_01” or “master 01” will always work.

Cheers!

I can see at least one of your files is ending with “L”

Please re-read my post, just updated it. I was able to narrow the issue down to 4 letters in combo with dash and underscore.

It is too much of a coincidence that the dashed letters at the end of the file names that do not work are?:
(-R)ight
(-L)eft
(-C)entre
(-S)urround

Definetly not a coincidence. These are probably reserved by Wavelab…

I’m getting it regardless of dashes or not, always when an “l” or “r” is at the end. Strange that you are not seeing the same.

@necromorbus: I tried l and r at the end with and without space and it works absolutely normal. Only when using L and R or l and r with dash or underscore preceding it at the end of the filename does the staggering feature fail. And for C, S it fails only with a dash. And as JimP has remarked, this is most likely connected to some internal Wavelab filename flags for Left, Right, Center and Surround. I’m certain for the Wavelab Dev team it’s no issue to fix, now that we have narrowed it down. A moderator just needs to make a bug report or CAN entry…

If you want me to recreate your issue with l and r, please post a video in which I can see your filenames. My guess is, you have a dash or underscore somewhere preceding the letter r or l (or a dash before c or s). If you have a filename with dash-r and one r without, it will still fail. But it will fail because of the former not the latter. Wavelab will stagger correctly until the file name with above criteria comes up, then it fails and starts staggering on multiple tracks. So its pretty simple to narrow it down.

See my previous posts for examples of file names that have caused issues. No dashes or underscores or spaces before the last letter.