Starting playback by double-clicking in the key editor ruler

In Dorico 5, double-clicking in the ruler in the Key Editor should start playback from that position and I’m pretty sure it used to do that for me, too after I updated to D5. However, that function is not working for me now and I expect I must have changed something in Preferences or Play Options but haven’t discovered what. Has anybody else run into this and sorted out a solution?

1 Like

I don’t think there are any options that govern this behaviour. I certainly find that it still works OK for me, both in the ruler in the piano roll in the Key Editor and in the track overview in Play mode.

Thanks, Daniel, for looking into this. I will be away even from my laptop for a few days but will see if I can get it working again when I return home.

@dspreadbury, I remain unable to start playback by double-clicking in the key editor ruler or track overview area. A single click moves the playback start line to the appropriate position but double-clicking makes no difference with any of several Dorico files both older and more recent that I have tried. I would find this feature very appealing if I could get it working and wonder if I can do anything to troubleshoot. I’m assuming it would be pointless to attach a diagnostic report as Dorico otherwise functions just fine. I am using an M1 Mac mini running Mac OS Ventura and Dorico 5.20.2042.

EDIT 3 hours later: As an experiment I tried opening D5 in Rosetta mode but this made no difference. I also opened a new test file with a few notes to see if something definitely started in D5 made a difference but again the answer was no. In case it helps I have attached a diagnostic report.

Dorico (643.9 KB)

Its not hardware (flaky/old mouse) related perhaps.?

No, I don’t think so. The double-clicking doesn’t work with either my Kensington Expert Mouse Wireless and M1 Mac mini or with the track pad on my older MacBook Pro.

However, I thought I would try triple-clicking and that does start playback on both machines. Triple-clicking feels clumsier than double-clicking but at least it works. As this problem arises on both of my systems I am mystified why I seem to be the only one experiencing this problem.

EDIT: I wanted to more definitively exclude the mouse as a factor and have since tried an alternative wired mouse with my M1 mini and this does not solve the problem.

As the same problem is present on both of my computers and may result from some common factor between them, I have attached a diagnostics report as well for my 2013 MacBook Pro running Mac OS 10.15.7 Catalina:

Dorico (443.4 KB)

I’m afraid I’m not sure how I could troubleshoot this, Mike. This is pretty simple stuff in terms of what the application is looking for. It has an explicit check for a double-click on the ruler, and if it detects the double-click it triggers the command to start playback from that position.

This might make no difference at all, but have you tried adjusting the double-click speed in System Preferences/Settings > Mouse?

1 Like

Thanks @dspreadbury. Hopefully the fact that payback does start with triple-clicking is helpful. There must be something that is causing Dorico to accept this but ignore the double-clicking it should be accepting. I am no programming expert but hope this is an important doorway into sorting out what is happening. A faulty mouse has been ruled out but it remains a mystery why this problem seems to be unique to me and yet occurs on both my Mac mini M1 and 2013 MacBook Pro. This might suggest the problem is related to software or a plug-in I have on both machines and I am hoping the two diagnostic reports are helpful in this respect although I don’t have the expertise to know.

Thanks for the suggestion @StevenJones01 ! It is well after 1 am here but I will check this out in the (much later) morning. I will be delighted if this turns out to be the source of the problem.

This website has some hopefully helpful information. One thing I didn’t know is that the Accessibility settings also influence how the mouse/pointer/trackpad behaves.

you’re not alone with this and I thought I’d also reported this somewhere. Double-clicking in the key editor has never worked with me and triple-clicking does sometimes. Double-clicking I notice sometimes resets the playback position to the beginning of the flow which is rather annoying. As I’m on a PC, it’s not a mac issue. Also I have no issues with double-clicking in any other context. Changing the double-click speed makes no difference.

As single-click plus spacebar works fine, this doesn’t in the least bother me (other than the mysterious move to beginning of flow)

@dko, thanks for clarifying this. It’s unfortunate you have the same difficulty but hopefully it will be useful for the Dorico team to know the problem is not narrowly confined to a single user.

Well, I tried various adjustments to the timing as outlined in your attachment but none had any effect on starting playback. As @dko22 experiences the same thing on Windows there must be something more than Mac OS settings at issue. Thanks again, it was definitely something worth trying.