starts recording a measure before..

hey all,

I dove into the deep end and have been been writing for 2 days straight with cubase to get the hang… I now feel really comfortable with the basics. Thanks for the help w the other posts.

I can’t seem to figure something out though… and I’m having trouble finding the answer on youtubes, manual etc.

When I record, say, 8 measures of a midi track, and then want to start recording again at measure 9 it seems to always start recording a measure before. In other words, the track ends fine at measure 8. Then I set the cursor on measure 9 and hit record, the metronome counts me in for a measure and then I start. Seems fine while I’m recording, but after I finish that chunk that I just recorded includes the measure BEFORE I started recording (ie, measure 8). Then it gets messy if I want to repeat that section because it has that extra measure at the beginning. I’ve included a screenshot to show what I mean-- see the overlap in midi 1 track? I haven’t had that issue before, and wondering if I accidentally activated some function.

Any ideas?


I bet the start of your first note is actually played a tiny bit early right at the very end of end of bar 8 extending into bar 9 and not the start of bar 9. You can verify by selecting the note in the Key Editor and checking its start time on the Info Line.

Ok- I’ll have to look at that later. Not sure how it would do that since I have the “snap to bar” set ,

Thanks for reply

Actually it could be any MIDI Data (e.g. cc data, program change…) and not just note data. But note data is typically the cause since it is common to play ahead of the beat. If you use the List Editor you can see if there is anything in that wayward measure.

Midi data has a resolution of 384 clicks per second. I don’t know about you? But I’ve known days I really couldn’t guarantee I could start recording on that exact o of a second on the new bar? :slight_smile:

So Cubase want’s to help you with your timing by automatically adding a pre-bar. If you want to be absolutely clean after a recording and have recorded notes prior to the 0 bar you didn’t intend just move them to 0 or further into the part and ‘cut’ the pre bar with the scissors. But it doesn’t matter to leave it because it might come in handy with for instance additional cc data?

Preferences „snap MIDI parts to bars“

Thanks— I think it was my sustain pedal… i re-recorded and waited on the pedal a smidge longer and it was fine. Thanks for the help!