Startup problems when switching ASIO devices

I need to use VST Live (like Cubase 12 currently) with different ASIO devices:

  • At home I usually connect an X32 mixer
  • In the band rehearsal room I have an UR22 (still the original, not the MK2)
  • And sometimes I would like to use simply the generic low latency driver, for example when preparing some setup changes or song notes on the sofa without an interface or keyboard connected

However, there is a problem.

So far, I only used VST Live (1.4.0.823) with the X32 and its ASIO driver, all fine. This morning, I tried to start VST Live with the X32 switched off, as I only wanted to do some quick checks, no need for audio.

But I got an error message at VST Live startup:

Hit OK and VST Live stopped. I would have expected a fallback to the low latency generic ASIO driver or at least prompt to choose the ASIO driver (like Cubase sometimes does at startup).

I tried to quit the X32 task bar control panel - this launches at startup no matter if the X32 is on or off, but normally makes no problems, even if I use an other audio interface. No difference, same VST Live startup error.

As I had my UR22 at home from a gig last Monday, I tried to connect this interface to see what happened in VST Live. Now VST Live was willing to start and showed me the startup screen with the low latency generic ASIO driver pre-selected:

So this does not seem to be a problem of needing to reinstall the generic driver as some users reported after their Cubase 13 upgrades.

I checked if the UR22 driver was also present - no problem:

I could now also open my project from the VST Live launch panel.

Then I closed VST Live, disconnected the UR22 and restarted VST LIve - same behavior as initially: “could not load an ASIO audio driver”.

Any ideas?

… we’ll check, again, thank you for reporting,
Michael.

Yes, it should attempt to load any ASIO driver available, until it succeeds. Generic would then probably the first choice, and there appears to be no reason why it should fail.

We will try to reproduce your case, thanks for reporting!

Hi @ChKK,

can you reproduce that one? If yes, could you please start the “ASIO Generic Lower Latency Driver Setup” application, create a screenshot of it and add it here? Just click to the Start/Windows button and enter “ASIO Generic …” then Windows should suggest the app.

Thank you,
Michael.

Yes, still reproducible.

Here is the screenshot from the driver’s config panel:

I noticed in the screenshot that no ports where shown - this is on purpose as I never use the generic driver and as part of the system tuning have disabled all non-ASIO audio devices (like the laptop’s internal Realtek Audio and the external monitor’s HDMI based audio).

So I tried to enabled one device for testing to see if this was causing the problems for VST Live:

And now VST Live was willing to start again … :slightly_smiling_face:

Then I disabled the Realtek Audio device and again, VST Live could not start if none of the ASIO devices was switched on.

As a final test, I tried to start Cubase 12 with the same audio setup. Selected the generic driver on startup:
6ih97t4n

Cubase 12 has no problems starting up even with no input/output ports available in the generic driver, so this seems to be something specific to VST Live.

… the “Generic Low Latency ASIO Driver” only works if it has an Output Ports. And VST Live only works if it has a valid driver. No audio, no VST Live.

Yes, Cubase can work without a valid ASIO driver. But there are several functions which will not work.

See you,
Michael.