Stationary Cursors are not stationary

I have “Stationary Cursors” selected in Preferences>Transport>Stationary Cursors. But when I play audio the cursor scrolls to the right and continues off of the monitor. It is not “stationary”. In fact, it disappears off my monitor altogether. Any suggestions on how to remedy this? Any key commands to enable stationary cursors? Thanks.

You have Auto-Scroll disabled. This means the background can’t move to keep the cursor stationary. It is the button with a thick arrow pointing right & a cursor cutting it in half.