Steinberg Activation Manager download from website failed


When I try to download the Mac version of activation manager from Cubase Pro 12 Downloads | Steinberg
I get error
"An error occurred while processing your request.

Reference #132.b6071502.1655223111.2dee69a"

Other downloads works on this page.

I tried another pc, same error. :frowning:

Confirmed. Link is broken.

Thank you for the confirmation. I hope someone from Steinberg will have a look at it.

@Matthias_Quellmann can someone from your team have a look at the steinberg website why the link is dead or provide a working link for the Mac download of Steinberg Activation Manager ?

best regards, Kurt

It’s working here. Give it another try.

Are you referring to the Mac version? Not loading here.


Yep, Mac version. Maybe it’s a regional thing? I’m in Canada.

Thank you Steve for confirming the error.
KT66, maybe is steinberg hosted on other servers for Canada? Here in Belgium it’s still broken. I tried 3 different internet providers and two different pc’s.

" An error occurred while processing your request.

Reference #132.9c071502.1655353974.e7a874f"

An error occurred while processing your request.

Reference #132.c7026268.1655368633.623b78cd

In the UK.

You can get it from here:


Thank you for the alternative working link :+1:

Btw, the original link is still broken.

I think the link should really be changed to

1 Like

I am sorry but the link and the downloaded file both work here. Which browser do you use and does it work with a different one?

I am still seeing the same message this morning

I got the same result in browsers: Brave and Edge and Chrome, using the following url :

Bu the link on this page works: Steinberg Activation Manager | Steinberg

Any browser on Windows or Mac (Firefox, Chrome, Edge, Safari)

An error occurred while processing your request.

Reference #132.c7026268.1657539556.a451af

I see now that the link is fixed for me. Thank you for fixing !

But before, the issue was on different browsers (safari, Firefox, chrome) , different OS (Mac, windows and Linux), different internet providers. All the same.

Hey @kurtg a couple links are referred to here, could you post the one you used successfuly?

These 2 links work now for me, the one in the original post:

and the one from the post of Phillipus:

For me it looks like the problem is solved.

Those are links to the page, but i thought we were talking about the actual download link on the pages.

Does this work for you?