Steinberg Activation Manager website authorization not working

Hi All,
I need help please
Im on windows 10 CB11pro no issues yamaha Asio device No issues till now.
I kinda had this niggling feeling about doing this upgrade but the price was perfect so i took the plunge and upgraded from 11 - 12
Now i’m thinking, it’s a simple process of installing over 11, right, Oh Nooo because after the 12 install, i encountered the not very friendly Authorize Steinberg Activation Manager screen. (altogether now BOOOOOO) and i was greeted with the below message

To authorize Steinberg Activation Manager, you must allow your browser to open Steinberg Activation Manager. Once authorization is completed, you can close this page and continue working with Steinberg Activation Manager.

Please can somebody explain why this is happening to me ? The fiddly fancy toys are in need of some unceasing

Screenshot attached
Any help, assistance, tips or guidance is /are greatly appreciated
Many Thanks

Do you have the Steinberg Activation Manager downloaded and installed? What you have open in that screenshot is the eLicense Control Center.

Cubase 12 uses a new program called Steinberg Activation Manager

Yes I have and the screenshot is where the SAM takes me to sign in, when I sign in, that dreaded message appears.
Everything looks fine license wise, but How do I get past this screen and into the SAM?
Help please

The page said “Try Again”. Maybe your login failed?

Please make sure to disable any VPNs, and that you’re not running script or ad blocking extensions. You can also try temporarily setting another browser (Edge, Firefox, Chrome…) as the default browser, or disabling your antivirus program.

If you continue to have issues, please contact Steinberg Support.

Thanks for the tip!
I’ve read a few post re this issue and I tried all of them edge chrome disabled all vpns and antivirus and still no access…
Appreciate your replies. Thanks
I’ll contact Steinberg (wish me luck)

Maybe you use the wrong login?

My login details take me to the screen as Shown, I try again and nothing happens.

That’s why I ask if the login is correct.
Make sure to use the MySteinberg login not the shop login…

That’s interesting!
My login details are the same for the shop, my Steinberg and the forums.
Is that/ could that be the problem? Perhaps?

Did you ever get any help with this ? I’m out of business right now because of this same exact issue. Tried to upgrade, and now can’t do anything. I will try calling support tomorrow.

Yes I did and it was so simple, I jumped back and slapped myself…

I did right click C12 and run as administrator ,i followed the prompts/ online window etc. it opened up the activation manger and all is great with world.
Hope it works 4 u

Hi Tommtom, write this with big gold letters on the sky pls :slight_smile:
Thanks a lot!

Hi - would you be able to elaborate on this? I right click Cubase (13) and it just opens as usual, and as I’m not currently activated because of this issue I get no progress