Steinberg Download Assistant 1.31.1 hangs up

Hello all,
On my macOS Monterey (12.1) on an Intel iMac I’ve downloaded and installed Steinberg Download Assistant 1.31.1.
When I launch it it hangs up forever.
Manually launching it from console I have the following error:

192:MacOS crosati$ ./Steinberg\ Download\ Assistant
09:18:53.881 [main] DEBUG - Lock file is: /Users/crosati/Library/Application Support/Steinberg/Download Assistant/net-steinberg-sda.4EA4CA71-30AB-4E8A-A087-757CA9B5E747.lock
09:18:53.891 [main] DEBUG - Message file is: /Users/crosati/Library/Application Support/Steinberg/Download Assistant/net-steinberg-sda.4EA4CA71-30AB-4E8A-A087-757CA9B5E747.message
Jan 13, 2022 9:18:54 AM tornadofx.Stylesheet$Companion detectAndInstallUrlHandler
INFO: Installing CSS url handler, since it was not picked up automatically
Exception in Preloader start method
Exception in thread "main" java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at org.springframework.boot.loader.Launcher.launch(
	at org.springframework.boot.loader.Launcher.launch(
	at org.springframework.boot.loader.JarLauncher.main(
Caused by: java.lang.RuntimeException: Exception in Preloader start method
	at com.sun.javafx.application.LauncherImpl.launchApplication1(
	at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$1(
Caused by: java.lang.ExceptionInInitializerError
	at javafx.scene.control.ProgressIndicator.createDefaultSkin(
	at javafx.scene.control.Control.impl_processCSS(
	at javafx.scene.Parent.impl_processCSS(
	at javafx.scene.Parent.impl_processCSS(
	at javafx.scene.Parent.impl_processCSS(
	at javafx.scene.Node.processCSS(
	at javafx.scene.Scene.doCSSPass(
	at javafx.scene.Scene.preferredSize(
	at javafx.scene.Scene.impl_preferredSize(
	at javafx.stage.Window$9.invalidated(
	at javafx.stage.Window.setShowing(
	at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$6(
	at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$7(
	at com.sun.javafx.application.PlatformImpl.lambda$null$5(
	at Method)
	at com.sun.javafx.application.PlatformImpl.lambda$runLater$6(
Caused by: java.lang.NullPointerException
	at com.sun.javafx.font.MacFontFinder.populateFontFileNameMap(
	at com.sun.javafx.font.PrismFontFactory.getFullNameToFileMap(
	at com.sun.javafx.font.PrismFontFactory.getFontResource(
	at com.sun.javafx.font.LogicalFont.getSlot0Resource(
	at com.sun.javafx.font.LogicalFont.getDefaultAAMode(
	at com.sun.javafx.font.LogicalFont.getStrike(
	at com.sun.javafx.font.PrismFont.getStrike(
	at com.sun.javafx.text.PrismTextLayout.setContent(
	at javafx.scene.text.Text.getTextLayout(
	at javafx.scene.text.Text.needsFullTextLayout(
	at javafx.scene.text.Text.access$200(
	at javafx.scene.text.Text$2.invalidated(
	at javafx.scene.text.Text.setText(
	at javafx.scene.text.Text.<init>(
	... 22 more

How can I install my Dorico 4 update?

You can download Dorico 4 manually via this page.

However, I think we’ll need to get Steinberg Download Assistant working on your computer so that you can perform the update. It’s worth trying, though, signing in with your Steinberg ID here and clicking the Redeem Download Access Code button. If your eLicenser is registered to your account (so that we can find your existing Dorico 3.5 license to mark it as updated), I think it will work OK this way.

Thank you Daniel, the manual installation and activation worked nicely.
Being a Java software programmer myself, I can help you and your team in testing the future fix of the Download Assistant, please let me know.

It would certainly be useful to have the logs from your machine. I will pass them on if you send them to me. The SDA team ask for the following information:

  • Mac/Win version (7/8/10/Mojave/Catalina, Home/Pro/Enterprise, 32/64bit)
  • SDA version
  • Steps to reproduce the error
  • Screenshot of the actual error
  • SDA installation logs. On windows: C:\ProgramData\Steinberg\Download Assistant\Logs\ – on mac: /Library/Logs/Steinberg/Download Assistant
  • SDA application logs. On windows: C:\Users<USERNAME>\AppData\Local\Steinberg Download Assistant\logs – on mac: ~/Library/Logs/Steinberg/Download Assistant
  • Whether antivirus software is installed and which exactly
  • Is VPN running?
  • Is any proxy configured?
  • Any other known firewall, apps or network configuration that might interfere with other applications or network?

(Note that on mac installation logs are located under “/Library/…” and application logs under “~/Library/…” - those are different directories)

Here the info:

  • macOS Monterey 12.1 on a iMac (Retina 5K, 27-inch, 2017) with 64 GB 2400 MHz DDR4;
  • SDA ver. 1.31.1;
  • Steps: Install SDA ver. 1.31.1 and launch it.
  • Screenshot: nothing is displayed on screen. Launching SDA via console I have the exception posted before;
  • (84.3 KB)
  • (37.1 KB)
  • No antivirus
  • No VPN running
  • No proxy configured
  • No firewall, apps or network configuration that might interfere with other applications or network.

Best regards,

Thanks for this info, Claudio. I’ve been in touch with our SDA team, and they suspect that the problem is caused by one or more fonts on your system that is causing an exception to be thrown. My colleague has put together a set of instructions for you to follow that will hopefully allow us to identify the problematic font, if you’re game to give it a try!

  1. Navigate to the Contents/Java folder inside the application bundle folder, e.g.

cd /Applications/Steinberg\ Download\ Assistant/Steinberg\ Download\

  1. Open file Steinberg Download Assistant.cfg and the property prism.debugfonts=true under the JVMOptions categrory. It looks something like this:
    -Dspring.config.additional-location=file:${HOME}/.config/steinberg-download-assistant/${HOME}/Library/Logs/Steinberg/Download Assistant/Steinberg-Download-Assistant_${sda.startup_time}.log
    -Daria2c.tool=/Library/Application Support/Steinberg/Download Assistant/3rd Party/optional/aria2/bin/aria2c


  1. Navigate to application folder inside the application bundle, e.g.

cd /Applications/Steinberg Download Assistant/Steinberg Download

  1. Start the Steinberg Download Assistant from the command line and monitor for exceptions,

./Steinberg\ Download\ Assistant

  1. Watch the log output and look for entries where the font name is “null", e.g.
    Jan 14, 2022 2:44:56 PM tornadofx.Stylesheet$Companion detectAndInstallUrlHandler
    INFO: Installing CSS url handler, since it was not picked up automatically
    Loading FontFactory com.sun.javafx.font.coretext.CTFactory
    Subpixel: enabled
    [MacFontFinder] Name=Shree Devanagari 714 Bold
        Family=Shree Devanagari 714
    [MacFontFinder] Name=Academy Engraved LET Plain:1.0
        Family=Academy Engraved LET
        File=/System/Library/Fonts/Supplemental/Academy Engraved LET Fonts.ttf
    [MacFontFinder] Name=null
  1. If there are fonts that provide a null for the name, moving them from the font folder might solve the problem.

Please let me know how you get on!

Thank you Daniel.
I’ve done what you wrote and I found a single entry matching “Name=null”:

[MacFontFinder] Name=null

Being that also “File=null” what I’ve done was removing all fonts from /Library/Fonts (but nothing changed), then from /Users/crosati/Library/Fonts, and at that point it worked. So using Newton bisection method I’ve moved back fonts until I’ve found:

  • MT Extra that blocked SDA from starting,
  • Arial, Arial Black, Arial Narrow and Arial Narrow Bold that were not loaded because of unknown format (these fonts are also in the system font as ttf extensions, so was not a problem removing them).

Now I have my SDA starting correctly. Thank you very much to you and your SDA team.

Thanks for letting me know, Claudio, and I’m glad you’ve resolved it.

The Download Assistant has never worked for me in the years I’ve owned Dorico. Not once, not ever. Support has tried many suggestions that didn’t work but we’ve always managed to get Dorico running.

Ok, I got Dorico 4 Pro downloaded, found a place on the web site to enter my Activation Code BUT it reads Verification Pending. I open the support link and it sends me to that damned Download Assistant. Apparently, it needs to reconcile my USB eLicenser before it can generate my real license.

I tried your solution. There are no fonts produce a Null. Download Assistant still doesn’t work.

I’m trying to upload the log but it won’t accept .txt, .rtf so I hope that .pdf works.

Downloas Assistant log.pdf (23.7 KB)

I also have an Intel — iMac Pro, MacOS 12.1 but it didn’t work on my last three Macs either.

I will ask my colleagues in the SDA team if they have any ideas about how to get the application running on your Mac, Mike. I’m sorry for the inconvenience caused.

This is the crash report I sent to Apple Engineering a few minutes ago in case it helps.

Crash Report Steinberg Download Assistant_2022-01-25-153742_Mac-c42c032e797e-6.pdf (2.6 MB)

Mike, I’ve been talking to a colleague about your case. The original log you posted a few days ago definitely suggests that the Java runtime environment is throwing an exception because of a font it doesn’t like, just like in Claudio’s case. We should try to figure this out, but in the meantime, you should be able to get up and running without needing Steinberg Download Assistant.

If you go to Sign in and click the Redeem Download Access Code button, then enter the Dorico 4 update DAC you received, you should be given an activation code, which you can copy to the clipboard and then enter in eLicenser Control Center. You can run eLicenser Control Center manually from the Applications folder on your Mac, then click Enter Activation Code, and paste in the activation code you were shown on the web site.

That should then mark your Dorico 3.5 license as upgraded, effectively completing the update process. Then in order to remove the “verification pending” notification in Steinberg Activation Manager (SAM), run SAM, choose to sign out using the account menu in the top right-hand corner, quit SAM, wait 20 seconds (so that the shared process used for licensing operations has time to exit), run SAM again, and sign back in. You should now see that the “verification pending” text has disappeared.

Thank you, Daniel, that did work.

I recommend that this page be updated since that solution is not mentioned. Titling it with a reference to the Download Assistant not running would be a big help.
Steinberg Licensing: “Verification Pending” support page
Had that been found on the page, I would have been up and running by now.

No argument there other than the directions you provided to Claudio did not show any such font on my system. Lord knows what old crap is sitting in my Fonts folder after 36 years. BTW, I cleaned out users/_/Library/Fonts and users/_/library/FontCollections years ago to solve other problems so I’m not unfamiliar with the havoc that they can wreak.

Fortunately, there has always been a workaround and I’m glad you found one this time. If Download Assistant is actually useful, it would be nice to experience that.

In the meantime, Apple has told me to expect an answer one way or the other by tomorrow or Monday. I’ll report back one way or the other. Who knows? They may find something useful.

Thanks, Mike

A week later, I heard back from Apple Engineering (many hours over 4 days) and they told me to kick this back to you. I could not get to anyone who would run a trace in real time to see what the hang up is, however, so that they couldn’t find what is not loading is no surprise.

On a whim, I decided to do a Safe Boot with the Shift key down. The Steinberg Download Assistant eventually ran many permission screens later. Of course, I had already resolved the License per your earlier directions.

So… I don’t know what the hangup is other than Apple telling me this is a Steinberg issue. However, since I have workarounds. we can kick the can down the road till next time, I suppose.

At this point, Mike, I can’t really think of a way of resolving this aside from trying the old “binary search”, e.g. move all of the fonts out of /Library/Fonts and ~/Library/Fonts and run SDA. If it then runs, which I would expect, put all of the fonts in /Library/Fonts back and run again: does it still run? If so, put all of the fonts from ~/Library/Fonts back, and run again: presumably it doesn’t, but now we’ve narrowed it down to the fonts in your user fonts folder.

So remove half of the fonts from your user fonts folder and run again: does it run? If so, then we know the problem is in the half you removed, so swap those two halves around and run again: presumably it now doesn’t. So now remove a further half… you get the idea.

Hopefully within a few minutes you could narrow it down to a small set of fonts that cause the problem.

In the meantime, it is allegedly the case that a newer version of the JDK runtime environment has fixed this problem – the bug, by the way, is in the JDK initialisation phase, which is executed before any of our own code in SDA is able to run, so we cannot actually fix the problem. So in theory we should be able to update to a newer version of the JDK in which this problem doesn’t occur, but I don’t know what the timeline for such a move will be.

Thanks for the reply.

Since Download Assistant does run correctly when my Mac is booted in Safe Mode, I’ll do the font test but it’ll have to wait till I have some time between deadlines. I am curious, however. That tip might be another item to add to the support document.


I’m in the middle of Apple Support Hell. Long story short, after updating to Monterey 12.2, something has been hanging up my system, I can’t get Apple to run a start-up trace to find the culprit and they’re talking about replacing hardware…

While going through every plug, license, app etc. making sure I was up to date, I found a culprit. Antares is using a run time from WIBU Systems called CodeMeter. Apparently, the version I had from 2018 was causing too many problems to count. Anyway, I downloaded and installed version 7.40 21-12-2021 and rebooted.
WiBu Support and Downlads

Most of my problems went away and Download Assistant now works.

I also found a few corrupted fonts that weren’t showing up in any reports.


I’m sorry that you’re going through support hell, Mike, but that’s interesting data, and I’m glad that at least Steinberg Download Assistant is now running on your system. Thanks for circling back to let us know.

1 Like