Steinberg Download Assistant crashes

Hi - I purchased Cubase Elements 11 earlier this week but am unable to launch Download Assistant in order to download it.

Whenever I try to run the Assistant I get the following error messages in succession:
Error Invoking Method
Failed to launch JVM

The assistant then bombs out.

I’ve tried re-installing, running as admin but make no difference. I logged a support ticket and chased but had no response.
Not very impressed with Steinberg service so far as an ex Cubase SX user. Can anyone help?

Running Windows 10, all patched, updated.

There was a new version of download assistant, the one which prompts you to enter a download code in top left of screen.
Mine DLA crashed until I spotted the update change.
The about info on my updated version says Version 1.19.10 Java Version Downloader Aria2 1.18.10

The version of the download assistant I have is v1.20.2 and still not launching with the same errors

Still no response from Steinberg on my ticket - over a week now since I purchased the software and unable to use it

Wonder if the reference to JVM is relating to a Java code problem, which might be external to DLA, just a thought given the way programmers seem to name things. Interesting that you have v1.20 Mac and PC versions obviously have differing update paths.
Support times are slow I have 3 tickets so far unanswered over a week old.


Please follow these steps:
Go to the Windows start menu
2. Type “cmd” in the search field
3. Locate “Command Prompt” result – don’t run it yet
4. Click the right mouse button and select “Run as Administrator” option
5. Type: sfc /scannow
6. Wait until the scan is finished.
7. Now type: DISM.exe /Online /Cleanup-image /Restorehealth
8. Wait until the scan is finished (Usually 10-30 min.)
9. You can close the command prompt now
10.Uninstall Steinberg Download Assistant
11. Delete all folders in theese locations
C:\Users\AppData\Local\Steinberg Download Assistant
C:\ProgramData\Steinberg\Download Assistant
C:\Program Files (x86)\Steinberg\Download Assistant
12.Install latest Steinberg Download Assistant
This should work.

Thanks for the response but this didn’t work unfortunately. I continue to have issues with SDA

Deleted by Kubbe

the latest versions of the SDA have all triggered a “network trojan” alert in my routers IDS and blocked it.
I downloaded the installer via VPN and scanned on virus total, all was clean… installed fine.
the next SDA update the same thing happened again, my IDS triggered an alert about a network trojan from steinberg

Its not unheard for malware scanners to detect legit apps with vulnerabilities - especially if they rely on opensource components or frameworks.
I’ve wasted about 2 hours this weekend trying to SDA configured following various articles - it still claims to not be able to see my download directory. Still awaiting a response from support (new ticket)