Steinberg Download Assistant does not start on MacOS Monterey

Hi all.
I’m trying to activate vst-instrument but SDA won’t start. After authorization, I click on Allow the page to open the application. But after that nothing happens, the program does not start.

MacOS Monterey 12.6.1

Hi and welcome to the forum,

You can start first Steinberg Download Assistant, then sign in and then just switch back to already started Steinberg Download Assistant.

No, that doesn’t work either. The Login button is still visible. And when I click on it, an authorization page opens with a small window asking permission to open the Steinberg Web Launcher. I press allow, the small window disappears, but the application still does not open, there is still the same Login button. When authorizing before clicking on the Login button, nothing changes.


There must be any kind of permissions…

Yes, I understand. But something doesn’t work. Although before the application started without problems.


When before? What has changed since then?

After installing the cubase, everything opened and everything worked, but now the application does not open.

OK. The problem is solved by a banal reinstallation of the application.