Steinberg Download Assistant is stuck on a finished Cubase 10 Download


I just bought the upgrade to Cubase 10. I downloaded the Steinberg Download Assistant to MAC and started downloading. It finished downloading the whole 21.44GB, but it now doesn’t go through to installation. It simply stuck in a mode of the status bar going back and forth from right to left. (See attachment)

I tried exiting the program and reopening it, but it comes back straight to the same state. At first I thought it might need to check some files, but it’s been about an hour and nothing happens. I wasn’t able to get a hold of the support anywhere, tried to call both UK and Germany lines, and they sent me here.

Would love to know how do I continue with the installation to use Cubase Pro 10.

Thank you

Exact same issue.Fully downloaded, but no way to open or locate file. Not a great start.

Same here…

Also, multiple components show up in my download assistant like Halion 6, Absolute VST3 collection, Wavelab Pro 9.5 etc… Are these additional addons that come with Cubase 10? Sorry if basic question but I’m new to this…

Steinberg DL assistant keeps crashing and there is no DL link under my products page.

Mine finally finished. All good here. I see now that I only needed to install Cubase 10.

Mine finished too. I think their servers were just overwhelmed with all the downloads and it slowed it all down. Hope everyone else managed to get it as well.

It takes about 5 minutes after the download has finished to prepare the large file.

Mine’s been stuck for about 20 minutes…

just wait. i was in the same issue, but just now it completed

Had the same issue. I ended up deleting a 3kb file (called Aria something) in the download folder. As soon as I did that the other file tuned into a rar with the cubase install folder.

Thanks for the tip - Worked for me too… after 2 hours of waiting.

Same here, freezes after complete download … Twice.
I have data limit on my internet connection, so, thank you, Steinberg …
I bought C10 a have nothing.

… what about direct link to installer ??

every link steinberg give you to download cubase send you straight to the download manager link… so far there doesnt seem to be a way to download directly… even the confirmation email with link sends you to the same place…

heres my money steinberg… “good boy… now bend over biatch” lol

I have no idea how to reinstall all my content. I think I am in a world of pain. I even uninstalled my old Cubase 7.5 and 8 installations so those wont mess up my clean install. Steinberg seriously has the worst installers. Last time I had to fight with the Halion 6 content. These are very expensive products.

Same problem here, I’ve been waiting for thirty minutes and nothing has finished, the loading progress bar still doing ping-pong!

So I did the “delete aria file” trick, renamed the 20 gb file to a zip file. The zip file appeared to be valid, but I couldn’t extract it - that was going at something like 50 kb/s, so I aborted that, and tried to double-click the msi file inside the zip. Lo and behold, Cubase was installed - super fast!

But: of course, it didn’t install any of the sound updates (vstsound, instruments and so on.).

My question: is it possible to install those (with the new Groove agent etc.) manually? The folders containing the contents are there.

Download assistant is showing error - connnection error. Can you provide a direct link to download. I had this issue when i downloaded 9.5. Then i got a direct link.

Has Steinberg addressed this? My download finished and for over an hour the bar has been going back and forth and nothing has happened. I tried deleting the aria file but it just keeps coming back. I’m on OSX.

Same here, trying to reload to do a fresh install of C10. It’s been over an hour since it downloaded, but it’s stalled with the blue back and forth thing. Man, I’m really tiring of these things with Steinberg; I mean, it’s 2019 and all.

If I stop Download Assistant program and erase the small aria file, will the download be able to be opened? It was fully downloaded over and hour ago and SDA is puttering about, won’t finish.