Steinberg Download Assistant issues

Just purchased the 9.5 upgrade from 9 from the Steinberg store. The Steinberg Download Assistant has installed fine but on loading it starts up and then the bar just spins for a minute and then says “connection to the download server could not be established”. I have updated Java to and Elicenser to the latest versions but still no luck. I’ve tried uninstalling and reinstalling but still nothing. I’m on a Windows 10 pc, 64 bit with 16gb of ram and internet is via an Ethernet cable. I’ve tried disabling AV programs and firewalls but still nothing. I have opened a ticket with support but know it may take a while.

Is there anyway to download the file directly, rather than using the download program or any other suggestions?

I think you should have an email message with download link of purchased upgrade.
I received one when I upgraded from Artist 9 to Artist 9.5. Then I received another message when I upgraded from Artist 9.5 to Pro 9.5.

Thanks for the reply Aneeman. I’ve just checked all the emails received but there’s none that link to any downloadable things. I’ve got the receipt, an invoice and an email with my license code but no where on them to install. In mysteinberg section online, I can see Cubase Pro 9.5 but when I click it, it just downloads the SDA again.

24 hours after purchase I’m still no closer to receiving the product. Is it possible/allowed to request someone on the forum to provide me with the Cubase 9.5 upgrade file from 9? The online shop can’t help me, Steinberg’s online support haven’t got back to me and the SDA still wont make a connection to the download server no matter what I try. Tried phoning the support line but even though it was open, I got a recorded message and then it hung up on me. Any help would be appreciated!

Honestly, I don’t know if this will help, but if your system can’t connect to the server it’s worth asking- are you using a VPN or proxy? If so try with it turned off, or, if you have access to a different ISP use that. I looked in the firewall rules list on my system, and there is no entry for the SDA, which is able to connect on my machine, which leads me to believe that it’s not a firewall issue. I’m just thinking of the possibility that there’s an internet routing issue, or your IP is being filtered somewhere along the route.

Sounds super frustrating. Hope you get it solved soon.

Thanks for the reply Steve. Yes it’s very frustrating! I use no VPN or proxy. Cubase 9 itself connects to the server on loading, as does everything else. I tried disabling anything I thought might cause issues (firewall/antivirus/network security) but still no luck. Everything else connects to the internet with no issues. I searched through the firewall list but there’s no mention of SDA anywhere. I guess I’m going to have to wait for Steinberg’s technical support to acknowledge my support request.

Hello,

you most likely have something messed up with your network settings.
I suggest reseting your network settings, it managed to solve my problem with download assistant.

This is called a WINSOCK RESET on windows
1/ Open the COMMAND console as an administrator.
2/ type the following command: netsh winsock reset
3/ Wait for the Command Prompt to run through the reset. Once it’s complete, you’ll see the message “Winsock reset completed successfully”.
4/ Restart your computer to finish.

Good Luck

Are you by any chance located in Russia?
Several users from Russia have reported issues connecting to the Steinberg’s download servers: https://www.steinberg.net/forums/viewtopic.php?p=742726#p742726

I am having a similar problem. I am trying to download the free trial version of Dorico to see if I want to buy it, but it keeps saying it can’t connect to the internet. I tried many of the solutions suggested in other threads, but still no luck. Is anyone able to help me with this?

I had this same problem installing this on my office computer where I teach school. My IT department told me that they would have to change their firewall settings to make this program work. They weren’t willing to do this.

Just wanted to pitch in on this. Seems to me like Steinbeg has enough customers as it is. I am trying to give Cubase Pro a trial here in the studio needing some fresh ways of composing, but… I only have endless problems getting anything going here. First they don’t say I need an eLicenser to get the Cubase Pro, then after installing 3 different softwares to get down the initial software I needed the eLicenser and I have bought it.

Now the Steinberg Download Assistant won’t even authorize.
I’m on Windows 10 btw.

If this is the way Steinberg follow up on the slogan “creativity first” I think they should do something about the cumbersome process of trying out their products and also all this verification nonsense. No other company want to deal with this anymore… except Avid and Adobe… omg…

Please help up!